19

I would like to open the terminal from the login screen. In previous Ubuntu releases I just used Ctrl+Alt+F1. However, when I press Ctrl+Alt+F1 in 18.04, nothing happens, the login screen just stays as it is. All other combinations with F-keys (F2 to F12) also have no effect whatsoever.

What key shortcut do I have to press to open the terminal from the login screen?

11
  • Do you mean tty screen?
    – Aryo Adhi
    Commented May 17, 2018 at 11:49
  • yes! is terminal not the right word?
    – Ethunxxx
    Commented May 17, 2018 at 11:52
  • @DavidFoerster Ok, I rephrased my question, hope it's better now.
    – Ethunxxx
    Commented May 17, 2018 at 13:18
  • 2
    Are you using a VM? Are your function keys actually function keys or one of those types that need to have an Fn key pressed additionally? What if you login and run sudo chvt 5?
    – muru
    Commented May 17, 2018 at 13:22
  • 1
    @muru I found a way to make it work: When I switch from the open-source to the proprietary NVIDIA driver, I can access tty without a problem. So apparently, it's a bug related to the open-source graphics drivers.
    – Ethunxxx
    Commented May 17, 2018 at 13:59

7 Answers 7

0

I had the same problem with ubuntu 16.04 on fresh install. Later everything started working. Try following:

sudo apt update
sudo apt upgrade

Run 'Software and Updates' and reboot

I knew answer is useless after so late but may help others

0

chvt [n]

Source: http://manpages.ubuntu.com/manpages/trusty/man1/chvt.1.html

And while in a tty, shift + {left,right} arrow key to change screens.

This can also be an issue with your login manager preventing the process. For example, some Ubuntu based distributions use SDDM as the default manager and there is a bug that can prevent changing ttys. A solution would be to disable your login manager and either starting Xorg with startx (with the appropriate commands in ~/.xinitrc) or systemctl start your-login-manager.

# systemctl disable sddm
# shutdown -hr now
...
login:
password:
$ startx
    or
$ sudo systemctl start sddm
0

I'm not sure if this fulfills your desired answer but at least it enables accessing the terminal as this answer is valid for the time being ubuntu release.

The trick is to access a virtual terminal. Pressing Ctrl+Alt+F3 (again, refer to ubuntu docs for release-specific commands) spawns a tty session which is similar to opening terminal, moreover, the keybinding opens entirely new parallel session (non-graphical user interface). If you are the owner (superuser), you have full access to all running sessions; this becomes especially helpful in emergency cases. As you can switch back to your first session using Ctrl+Alt+F2 or Ctrl+Alt+F7 as referenced here

0

Enable Fn Lock by pressing Fn+Esc. Then try again.

0

A new default configuration introduced to systemd around this time no longer allocates a graphical VT at a fixed tty7. Instead, tty1 is allocated to the display manager (gdm in Ubuntu Desktop), and new graphical consoles are allocated on other VTs when a user logins.

Right after boot when the graphical login screen shows up, the status of VTs may look like this:

tty1: gdm
tty2: (unallocated)
tty3: (unallocated)
tty4: (unallocated)
tty5: (unallocated)
tty6: (unallocated)

Once you log in, the new session would not appear at tty1 but at tty2:

tty1: gdm
tty2: gnome-shell
tty3: (unallocated)
tty4: (unallocated)
tty5: (unallocated)
tty6: (unallocated)

You can still pull up text mode sessions by switching to an unallocated VT in the tty1-tty6 range, which would automatically start agetty (and in turn text mode login) on that VT. The shortcut is CtrlAltFx from gdm, or simply AltFx from a text console, where x is a number key from 1 to 6.

If you have ever started a text session on tty2 before logging in from gdm, however, the graphical session will start on tty3, since tty2 is already used for text console.

tty1: gdm
tty2: text console
tty3: gnome-shell
tty4: (unallocated)
tty5: (unallocated)
tty6: (unallocated)
0

You can by pressing the combination button

Ctrl + alt + T

Call the terminal

2
  • That's not correct actually. Ctrl+Alt+T works only from a GUI session, that is after the user logs in. What the OP wants is launch a virtual terminal before logging in. It's just that the OP is confused about the terminology (I don't blame them) that made them ask about "terminal" and has probably led you to post this answer. Related: What's the difference between the TTY and the GNOME terminal? Commented Mar 24 at 8:51
  • Thank you very much for your attention, I just gave my opinion that it might help, I hope he can solve his problem. Currently, I have just migrated from Windows to the Linux world. I am a beginner and I am learning.
    – Mehdi
    Commented Mar 24 at 8:59
0

You can press ctrl+alt+f4 to access tty screen. To exit it, you can press f1.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .