2

This question already has an answer here:

The thing is that I decided to install Ubuntu 18.04 LTS (had 17.10 before) and everything was fine, I could open desktop folders. I don't know how, but some days ago suddenly I couldn't open theses folders by double clicking on them or even right clicking and trying to open as a new window. I can open these folders with Nautilus(default file browser) and can even delete them and some more options like rename (as double clicking on them at desktop) and can also open desktop files by double clicking. The problem is just with folders on desktop. I tried to look for a solution but nothing worked at the moment so I hope someone could help me with this. I am using GNOME desktop environment.

@ArchismanPanigrahi First i did a clean install and it worked fine but i started to install some gnome extensions and suddenly dunno with which one it doesnt work anymore. The thing is i disabled all the extensions and keep not working. I am running 18.074 with ComunityTheme but it doesnt work with normal enviroment. I wish this info can be useful for u, anything u need just comment, sorry for answering late but I was kinda bussy. Thanks

@DavidFoerster Yeah, i tryed to enter as guest user and the problem continues, i think it could be a nautilus problem maybe but was looking for info and tryed to reinstall, nothing worked at the moment. Its not a really serious problem but would like to know why this is happening, i just found one guy in Ubuntu Reddit who has exactly the same problem and no solution, i will try to solve this again because i was kinda bussy and didnt got time to continue. Anywway thx for your help and sorry for the late answer.

EDIT 1: Still no solution found, formatting would solve this but dont want to do this.

EDIT 2: Tryed to remove nautilus and use Nemo as main file browser and have the same problem so i dont think its a nautilus problem.

EDIT 3: I found this article and not sure if could be the answer for my question. If anyone knows comment, thanks. https://www.omgubuntu.co.uk/2018/01/gnome-desktop-icons-removed-3-28

marked as duplicate by terdon Nov 13 '18 at 19:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you perform an upgrade or was it a clean install? – Archisman Panigrahi Jun 3 '18 at 3:52
  • Can you please log in as a guest user (or create a new temporary user account) and check if the same problem occurs with its desktop? Thanks – David Foerster Jun 3 '18 at 9:29
  • Could you please edit your post when you want to clarify something or add information? It’s best to have everything relevant in one place. Additionally, comments may be deleted for various reasons. Thanks. – David Foerster Jun 21 '18 at 13:58
  • Could it be possible the user upgraded to the version of Nautilus where there is no desktop folder with Gnome ? – user227495 Jul 13 '18 at 9:15
  • All else failing, you may first try an approach that is less drastic than formatting, i.e. resetting all dconf user preferences with the command "conf reset -f /". Warning: this will reset all settings to factory default. – vanadium Jul 13 '18 at 10:43
0

I just experienced the same problem-not being able to open the folders on my desktop, but I could open Nautilus, and from there, open the folders.

What I ended up doing is:

  • From the Desktop - Right Click on the Folder
  • Select- Open With Other Application
  • Select- Nautilus

That worked for me. Just checked it again before Posting this, still works.

            .-/+oossssoo+/-.                   
        `:+ssssssssssssssssss+:`           --- 
      -+ssssssssssssssssssyyssss+-         OS: Ubuntu 18.04.1 LTS x86_64 
    .ossssssssssssssssssdMMMNysssso.       Kernel: 4.15.0-38-generic 
   /ssssssssssshdmmNNmmyNMMMMhssssss/      Uptime: 31 mins 
  +ssssssssshmydMMMMMMMNddddyssssssss+     Packages: 2521 (dpkg), 24 (snap) 
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/    Shell: bash 4.4.19 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Resolution: 1920x1080 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   DE: GNOME 3.28.3 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM: GNOME Shell 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM Theme: Adwaita 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Theme: Ambiance [GTK2/3] 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Icons: ubuntu-mono-dark [GTK2/3] 
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/    Terminal: gnome-terminal 
  +sssssssssdmydMMMMMMMMddddyssssssss+     CPU: Intel i5-6400 (4) @ 3.300GHz 
   /ssssssssssshdmNNNNmyNMMMMhssssss/      GPU: Intel HD Graphics 530 
    .ossssssssssssssssssdMMMNysssso.       Memory: 2225MiB / 62508MiB 
      -+sssssssssssssssssyyyssss+-
        `:+ssssssssssssssssss+:`                                   
            .-/+oossssoo+/-.
-1

This was a recent change to Nautilus. You can open the file manager and access Desktop files from there.

I recommend installing Nemo.

Nemo will handle the desktop in lieu of Nautilus.

Open a terminal session (Gnome terminal,...)

sudo apt-get install nemo 

or go to the software center and search for it.

You also can get the deb package from https://pkgs.org/

P.S. DO NOT remove Nautilus ...........

You can use dconf to edit desktop preferences

https://pkgs.org/download/dconf

Not the answer you're looking for? Browse other questions tagged or ask your own question.