I'm trying to run Xen on Ubuntu Server 11.10. I tried following the wiki, but it's a bit obsolete, so I tried following a blog post. Everything seemed to be going well, until I ran virsh version, which shows:

Compiled against library: libvir 0.9.2
Using library: libvir 0.9.2
Using API: Xen 3.0.1
Cannot extract running Xen hypervisor version

Oddly, when I booted, I manually selected the Xen kernel...but then a second Grub menu appeared, requiring I select a "normal" Ubuntu kernel.

Also, when I ran grep vmx /proc/cpuinfo, it showed my CPU (an Intel Xeon E3-1230) had VT support. But now when I run it, it doesn't show anything, which is weird because Intel's docs explicitly say it has VT support.

How do I determine what went wrong and fix it? Is there an official guide on installing Xen on Ubuntu 11.10?


I think you might have to be root to start talking to the xm binary. Does sudo virsh version offer different output? my response is based off the following post.


Having said all that, unless you have a legacy application that requires Xen I would suggest you migrate to KVM. It's just all round better supported on Ubuntu. Good luck.


You shouldn't be getting a second grub menu. If you install the xen package, it adds the xen entries to the grub menu, and when you choose the xen option, the system should just appear to boot normally. You can then use the xm command to start additional xen domains. The reason you don't see the vmx support is because xen is using it, so it doesn't reveal it to the virtual machines running under xen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.