0

I recently updated my Ubuntu from 16.04 to 18.04, and one problem is the icon for the executable is the same as the one for a text file. (ArucoDetect is an executable, and others are usual text files)

ArucoDetect is an executable

In Ubuntu 16.04, the executable have it's own icon like

executable

How can I configure Ubuntu 18.04 so the executable can have it's own special icon?

2

If you have problem than you can find gcc and add line -no-pie It is default executable because Ubuntu 18.04 has problem with Wayland that is why position independent executable. Just no pie! Than it works fine for me.

  • I tried compiled with -no-pie (only one dash in the front) and it solves it. Do you know whether there's any downside for compiling with this flag? – user3667089 Jan 31 at 22:24
  • Check makefile! You can find "gcc" with end of compilation like gcc main.c -o executable -no-pie than you see an executable and you can click executable. or ./executable in terminal. // UPDATED i.imgur.com/SFoD5uB.png – Jens Eckervogt Jan 31 at 23:07
0

Change your application's name to ArucoDetect.appimage

  • It does changes the icon by adding .appimage but shouldn't it work without having to add that extension? – user3667089 Jun 7 '18 at 18:37
  • Is this the same Problem? stackoverflow.com/questions/50412577/… – Tim Jun 7 '18 at 19:18
  • No this file is an executable. Even if I do chmod a+x again on the file the icon still doesn't change. – user3667089 Jun 7 '18 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.