0

I used to use mainline kernel 4.16.3, and most things worked fine. For testing purposes, I tried 4.16.9 by running sudo dpkg -i linux-image-unsigned-4.16.9-041609-generic_4.16.9-041609.201805161024_amd64.deb linux-modules-4.16.9-041609-generic_4.16.9-041609.201805161024_amd64.deb. With this kernel, booting took really long (more than 2 minutes) and produced the following output: https://nopaste.xyz/?4b741a33276d0461#B3BbGFMFUIhZAjBGivihzmK5oUu/1DsxKlTEPxtnvp8=

Disabling apt-daily.service like recommended in Ubuntu 16.04 slow boot (apt-daily.service) did not change anything (but systemd-analyze blame showed a similiar order, with apt-daily.service on top.

Due to the syslog, I assume there is some snappy incompatibility. Is my installation of the kernel somehow wrong or may this be a bug?

2

Unfortunately this is a bug. All the kernels from K4.16.3> onwards have the same problem this includes K4.16.9, plus the K4.17RC's. I don’t know why these have been allowed to be available to the public space. The frustration I have is that there is no explanation as to why. One can accept that sometimes kernels that are maintenance releases might have some minor bugs but nothing like this where the kernel crashes entire systems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.