This is a similar problem to this post but I was unable to add to the comments since I am new to StackExchange. I tried the answer posted by Vishesh but it didn't solve the issue for me; when I run start-pulseaudio-x11 command it still says "Failure: Module initialization failed". However, the sound works for all my other applications (VLC, Rhythmbox, web-based audio such as YouTube and SoundCloud). I have not tried the solution posted by Vikas as I wasn't sure whether it would impact my applications that do have audio output.

The problem started when I switched my audio output to HDMI; I had plugged my computer into my TV.

Is anyone else experiencing this issue?

  • 4
    can you change the output in system settings -> sound -> applications? May 16, 2018 at 21:25
  • It shows Spotify in the list under applications, sound is up full but still nothing from the app. I also tried to delete and reinstall the app with no success
    – JJGabe
    May 17, 2018 at 14:19
  • An update to this issue: I still get full sound through an HDMI cable when its plugged into my TV. Does anyone know how to reset this in Spotify? All my other applications are working
    – JJGabe
    Jul 13, 2018 at 17:27
  • The pavucontrol solution worked for me.... for no apparent reason spotify was muted. I just hit unmute and I started to hear the music. The funny thing is... I had closed spotify.... I can see it in the process list but the spotify app is not on my desktop...
    – Patrick
    Sep 26, 2019 at 1:11

2 Answers 2


The simplest solution is to install pavucontrol sudo apt install pavucontrol. Then you launch it and the gui will let you choose the output for each application.

  • 2
    Easy to operate and worked greatly. Aug 15, 2019 at 6:33
  • I am running Budgie and there are sound output controls easily accessible through the applet window however they weren't able to solve the problem. After I had unplugged the HDMI cable it was no longer listed as an output option and the check mark was beside Built-in Audio. Do you know if pavucontrol does a better job at controlling the sound devices?
    – JJGabe
    Sep 10, 2019 at 18:46
  • Yes, that's the point (testing it could have been faster than type the comment).
    – jona303
    Sep 12, 2019 at 12:10
  • this needs to be the recommended solution!
    – jenkizenki
    Apr 17, 2020 at 1:17
  • Thanks, I felt quite dumb plugging and unplugging my cables, mirroring my displays, etc. until I decided to read your answer.
    – sbaldrich
    May 5, 2020 at 11:08

Yes, I experienced a similar problem today but not just with Spotify.
In my case, no application was able to play the sound.
Only system sounds were coming.
This occured after I had plugged my laptop to my TV using HDMI cable and then unplugged it.

This is how I solved it.

  1. Connect your PC back to the Device using HDMI port
  2. Go to display and mirror the screens
  3. Go to settings>sound.
  4. Change the audio output to the HDMI device
  5. Change the audio output back to the laptop/PC
  6. Go to display and switch back to your laptop screen
  7. Unplug the HDMI cable
  • yes, flicking to digital spdif, then back to hdmi seems to solved it! Aug 4, 2018 at 13:27
  • This also worked for me, thanks @coderDude! Strange that it was only Spotify affected for me..
    – JJGabe
    Sep 11, 2018 at 14:32
  • worked on arch linux as well. Thanks so much
    – aaaaaa
    May 19, 2019 at 15:49
  • This didn't worked for me. I recomend to choose the comment above as the acepted answer Jun 26, 2020 at 10:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .