1

Currently i am using Ubuntu 18.04 and Whenever i turn on my laptop after loading Ubuntu icon screen the screen rotates on User login screen even when laptop is not rotated. And it shows two cursors and from them the original cursor became vanish and only the mirrored cursor exist. After logout and logging in again fixed this issue but it is very annoying and even i set screen rotation lock.

3 Answers 3

2

You might need to blacklist the module in question, first, try to unload the module from your RAM.

sudo modprobe -r lis3lv02d

If it doesn't work, you can try to identify which module enable your motion sensor with the following command

sudo cat /proc/bus/input/devices

Finally, if your blacklist command fixed the issue, make the change permanent with

editor /etc/modprobe.d/blacklist.conf

And add the following line at the end of the file (probably empty)

blacklist lis3lv02d
1
  • That doesn't worked
    – Ayu
    May 28, 2018 at 10:54
1

On a HP laptop (e.g. the EliteBook 840 G3 I have), you can instead remove the module hp_accel:

sudo rmmod hp_accel

This is better because usually lis31v02d will probably by "in use" - it's known as a "dependency". Because it's being used, you can't remove it, so the above suggestion removes the module that relies on it. The side effect of removing the "parent" module is that the "child" module is also removed.

1

This feature hasn't been useful to me personally so I just remove it right away when I install Gnome. If you want to remove this feature then fire below commands :

Try this command to stop and disable

$ sudo systemctl stop iio-sensor-proxy.service
$ sudo systemctl disable iio-sensor-proxy.service

Try this command to remove

$ sudo apt-get remove iio-sensor-proxy

Curtosy : https://askubuntu.com/a/1059678/834205

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .