8

I use Ubuntu dual boot with Windows. I recently updated my BIOS from the Acer official website for increased performance, but after updating the BIOS, I am not able to boot Ubuntu. Earlier I used the Windows Boot Manager screen to boot to Ubuntu which appeared after I pressed F12 on my laptop. The boot screen does not show the option for Ubuntu.

1
  • BIOS/UEFI updates often reset UEFI/BIOS settings back to defaults. You may have to re-enable trust on the Ubuntu/grub .efi boot files. With BIOS I had many settings and took photos. With my newer UEFI desktop, it lists changes it makes when saving, so I document those to make it easier next time I update UEFI.
    – oldfred
    May 16 '18 at 14:25
9

I have encountered a similar problem. This worked for me.

  1. Log-in to Windows using your Administrative account.
    Right click on windows icon and select command prompt(admin).
    Run this from the command prompt:
    bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
    This will make Grub the default boot manager. Then in the Grub menu, you will find both Windows and Ubuntu.
  2. If in the Grub menu you could not find Windows bootloader then, select the advanced option (which is just below Ubuntu) in Grub menu. Then select Ubuntu(Recovery Mode). There you will find update grub. Select it and press enter. It will fix the problem and then in Grub menu there will be Windows boot loader.
    http://myviewsonfoss.blogspot.in/2018/05/how-to-fix-grub.html
4
  • I just discovered that there was a Unknown device option also present in the boot manager and when selected it boots to Ubuntu May 16 '18 at 16:23
  • In which boot manager? Grub or Windows? Anyway, could you find both windows & Ubuntu there? Your comment lacks specific info. Please provide in details. Thanks.
    – Debajyoti
    May 16 '18 at 16:29
  • It was a BIOS boot manager with two options : 'Windows BOOT Manager' and 'Unknown Device' May 17 '18 at 17:17
  • The first step works! Just copy and paste! Tried many other methods but this one finally works! Thanks! Dec 28 '19 at 12:03
2

Boot into Live Ubuntu flash drive. R. click desktop and Open Terminal.

Enter commands:

sudo add-apt-repository ppa:yannubuntu/boot-repair then

sudo apt-get update then

sudo apt-get install boot-repair

Once installed, run command: boot-repair and follow the instructions and wait for program to complete. You should get a message whether boot-repair was successful.

If so, restart your computer, go into BIOS and check that Ubuntu exists as an HDD option, and ensure it's first boot option. Then save BIOS settings and restart computer.

2

The following worked for me:

1) Enter BIOS.

2) Change startup priority so Ubuntu goes first (on top).

This is a similar solution to that from arnav. But I had no need to change other UEFI settings, only the boot priority.

2
  • This is the best and simple answer. All other answers add unnecessary complexities Jul 3 at 14:40
  • Useless if the disk doesn't even show up in the HDD boot list at all, isn't it?
    – Benjamin R
    Jul 22 at 12:58
1

This happens because on updating BIOS, its preferences and settings changes to default i.e. mode gets set to Legacy mode instead of UEFI mode, also the order of UEFI is reset to put windows first and ubuntu later so just switching mode won't work, you will also have to change order. Follow these steps(f1 or f2 keys may differ on different laptops)

1. Restart System and enter BIOS (using f2 key or other)
2. Change the mode from Legacy to UEFI
3. Change the order of UEFI to put Ubuntu on top, atop Windows. This will ensure that grub menu is loaded on startup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.