0

I have a MSI GX70 gaming computer that I converted into a coding computer. I installed Ubuntu but its GPU (AMD Radeon HD 8970M) is giving me trouble.

Ubuntu 14 + Oibaf seemed to run fine, however, since I accidentally broke my OS yesterday (sudo apt-get remove python wasn't a very good idea) I thought that I might as well upgrade the distribution.

I tried Ubuntu 18 and 16. Both installations went fine. However, when I boot on drive after installation, I can't get past login. Screen becomes black and my laptop reboots.

I'm currently on my fresh Ubuntu 18 that I booted with nomodeset. Native Radeon module didn't work, neither did Oibaf. I haven't tried AMPDGPU-PRO, but it didn't work last time I tried on Xenial (login loop). And there are no proprietary driver for this GPU past Ubuntu 14 (I couldn't get fglrx to work on 14 anyway, that's why I used Oibaf instead)

There might also be a power problem but I haven't investigated this beyond disabling acpi.

Is there a way to fix this problem ? (other than downgrading to Ubuntu 14 or permanently add nomodeset to GRUB)

0

Try to add to grub radeon.modeset=0 to this line :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

that it reads :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"

works better for me than "nomodeset"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.