I have a very frustrating problem with my PC. I cannot install any recent version of Ubuntu Server (or even Desktop) since 9.04 even using the text-based installer. I boot from a USB stick created by Unetbootin (I also tried other methods such as startup disk creator with no difference).

On the Server installer, it gets to "Detecting Hardware" (the second one about disks and all other hardware, not network hardware) and then either hangs at 0% (waited 24 hours), or reboots after a minute or two.

My system (late 2007):

  • ASUS P5NSLI motherboard
  • Intel Core 2 Duo E6600 2.4Ghz
  • 2 x 1GB Corsair 667MHz RAM
  • nVidia GeForce 6600

I have unplugged everything (including the only hard disk, CD-ROMs and floppy). I have only one stick of RAM (tried each one to no avail) and am booting the installer from a USB stick (booting from CD-ROM yields the same problem). I also tried several of the boot options (nomodeset, nousb, acpi=off, noapic, i915.modeset=1/0, xforcevesa) in all combinations) to no avail. The only active parts of my system are the video card, mouse, keyboard and USB stick.

I have also updated the BIOS to the most recent version.

(FWIW, on the Desktop installer, I get a black screen after hitting the Install option.)

Even after removing "quiet" I am unable to see what kernel panic is occurring (or not occurring) to cause the install to crash. I am only able to save the debug logs via a simple webserver in the installer. After the last line (I repeatedly refreshed), the server stops responding and the installer hangs or reboots:

Jan  2 01:04:03 main-menu[302]: INFO: Menu item 'disk-detect' selected
Jan  2 01:04:04 kernel: [  309.154372] sata_nv 0000:00:0e.0: version 3.5
Jan  2 01:04:04 kernel: [  309.154409] sata_nv 0000:00:0e.0: Using SWNCQ mode
Jan  2 01:04:04 kernel: [  309.154531] sata_nv 0000:00:0e.0: setting latency timer to 64
Jan  2 01:04:04 kernel: [  309.164442] scsi0 : sata_nv
Jan  2 01:04:04 kernel: [  309.167610] scsi1 : sata_nv
Jan  2 01:04:04 kernel: [  309.167762] ata1: SATA max UDMA/133 cmd 0x9f0 ctl 0xbf0 bmdma 0xd400 irq 10
Jan  2 01:04:04 kernel: [  309.167774] ata2: SATA max UDMA/133 cmd 0x970 ctl 0xb70 bmdma 0xd408 irq 10
Jan  2 01:04:04 kernel: [  309.167948] sata_nv 0000:00:0f.0: Using SWNCQ mode
Jan  2 01:04:04 kernel: [  309.168071] sata_nv 0000:00:0f.0: setting latency timer to 64
Jan  2 01:04:04 kernel: [  309.171931] scsi2 : sata_nv
Jan  2 01:04:04 kernel: [  309.173793] scsi3 : sata_nv
Jan  2 01:04:04 kernel: [  309.173943] ata3: SATA max UDMA/133 cmd 0x9e0 ctl 0xbe0 bmdma 0xe800 irq 11
Jan  2 01:04:04 kernel: [  309.173954] ata4: SATA max UDMA/133 cmd 0x960 ctl 0xb60 bmdma 0xe808 irq 11
Jan  2 01:04:04 kernel: [  309.174061] pata_amd 0000:00:0d.0: version 0.4.1
Jan  2 01:04:04 kernel: [  309.174160] pata_amd 0000:00:0d.0: setting latency timer to 64
Jan  2 01:04:04 kernel: [  309.177045] scsi4 : pata_amd
Jan  2 01:04:04 kernel: [  309.178628] scsi5 : pata_amd
Jan  2 01:04:04 kernel: [  309.178801] ata5: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xf000 irq 14
Jan  2 01:04:04 kernel: [  309.178811] ata6: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xf008 irq 15
Jan  2 01:04:04 net/hw-detect.hotplug: Detected hotpluggable network interface eth0
Jan  2 01:04:04 net/hw-detect.hotplug: Detected hotpluggable network interface lo
Jan  2 01:04:04 kernel: [  309.485062] ata3: SATA link down (SStatus 0 SControl 300)
Jan  2 01:04:04 kernel: [  309.633094] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Jan  2 01:04:04 kernel: [  309.641647] ata1.00: ATA-8: ST31000528AS, CC38, max UDMA/133
Jan  2 01:04:04 kernel: [  309.641658] ata1.00: 1953525168 sectors, multi 1: LBA48 NCQ (depth 31/32)
Jan  2 01:04:04 kernel: [  309.657614] ata1.00: configured for UDMA/133
Jan  2 01:04:04 kernel: [  309.657969] scsi 0:0:0:0: Direct-Access     ATA      ST31000528AS     CC38 PQ: 0 ANSI: 5
Jan  2 01:04:04 kernel: [  309.658482] sd 0:0:0:0: Attached scsi generic sg0 type 0
Jan  2 01:04:04 kernel: [  309.658588] sd 0:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
Jan  2 01:04:04 kernel: [  309.658812] sd 0:0:0:0: [sda] Write Protect is off
Jan  2 01:04:04 kernel: [  309.658823] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
Jan  2 01:04:04 kernel: [  309.658918] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Jan  2 01:04:04 kernel: [  309.675630]  sda: sda1 sda2
Jan  2 01:04:04 kernel: [  309.676440] sd 0:0:0:0: [sda] Attached SCSI disk
Jan  2 01:04:05 kernel: [  309.969102] ata2: SATA link down (SStatus 0 SControl 300)
Jan  2 01:04:05 kernel: [  310.281137] ata4: SATA link down (SStatus 0 SControl 300)

Anybody have any additional ideas I could try? I am getting ready to just toss the motherboard.

  • 1
    Can you state the boot options tried - e.g. acpi=off or noapic or nousb – fossfreedom Feb 12 '12 at 21:29
  • Modified my question to include these. I also tried acpi=off and nousb (I hadn't tried those yet), but same issue. Reboots soon after "Detecting hardware" comes up (disk detection). – Ryan Rosario Feb 12 '12 at 22:03
  • is this a single IDE HDD install or some-sort of RAID? I would have expected that acpi=off nousb nomodeset would have force the install. If you remove quiet splash do you have time to see what is causing the kernel panic? – fossfreedom Feb 12 '12 at 22:20
  • This is a single SATA HDD. The installer crashes/reboots/hangs even with no HD plugged in. I removed "quiet" but the text-based GUI seems to cover up any messages. I turned on debug logs via simple web server. This is as far as I am able to get. After the last message, the web server stops responding and the install hangs. The log is in my question now. – Ryan Rosario Feb 12 '12 at 22:51
  • ... oops - I forgot to ask - what version of ubuntu are you trying to install? Are you trying to install 32bit ubuntu or 64bit? Have you tried 32bit if you've been working with the 64bit ubuntu? Have you tried the new 12.04 alpha? Sorry for all the questions - I'm hoping all of this info will help someone pin down what the issue is... – fossfreedom Feb 12 '12 at 23:01

Seems to me its related to your disks. Some Bioses have an option for tweaking disk controller mode. Between "modern" and legacy. Check your bios if you have such an option. Try toggling it and see if the installer gets any further.

  • 1
    Yes to this. I've had similar problems with SATA and not-brand-new but still current hardware. There's a bios setting like ACHI vs SATA. Oh, and nVidia means you will need nomodeset to install. I have lots of nVidia hardware at my business. – Chris K Jun 13 '12 at 23:36
  • @ChrisK I am currently using an Nvidia on two boxes(a GTX 680 and a chpiset 6150se), and have never had to even look at nomodeset. – hexafraction Jun 20 '12 at 18:23

I found this discussion of a similar issue that was addressed by disabling RAID features in the BIOS.


Based on the manual for your motherboard ( http://dlcdnet.asus.com/pub/ASUS/mb/socket775/P5NSLI/e2234_p5nsli.pdf ) you should navigate to Advanced > Onboard Devices Configuration > NVRAID Configuration and disable NVRAID.

If this doesn't work, have you tried swapping the power supply? I have seen a wide variety of issues, including disk issues similar to this one caused by power supply issues. It's definitely worth trying.

You say that the problem occurs even with no disks in the system? When you tested with no disks were you using an optical drive or a USB stick? I'm particularly interested to know if you had any SATA devices connected. If you did it would be interesting to test with no drives and a USB stick to see if you can recreate the failure. It would also be interesting to try the installer with a PATA disk and see if you can install to that.

  • No RAID, and I have switched disks. I have not tried a different power supply, CPU or motherboard (I am leaning motherboard). I have tried USB, DVD both with and without SATA (every combo) to no avail. I am hoping to update this thread once I find the culprit. – Ryan Rosario Mar 22 '12 at 18:56

Do you have any other computer that you can completely install Ubuntu GNU/Linux on, update it all the way.. then put that drive into the computer for this post to see if it boots/works? That's what I would try.

Also, I would try some different RAM (if available). Also, will a different distro install successfully? And, does the LiveCD boot to the Desktop successfully?

Also, I have an older motherboard with Ubuntu loaded on it that would go into a reboot loop because the way the RAID controller was loading itself in at startup. There was some conflict where the RAID bios would interfere with the boot sectors on the SATA drive. There's some way to use dd to move the boot sector around and fix it but what I ended up doing was plugging an older small IDE drive that I had and installing the /boot directory (only) on it for Ubuntu. Been working since. I see from your mobo picture that you have an IDE slot, so maybe if you have no way to disable RAID, you can try installing on an IDE hard drive to test.

This bug post has the history (and possible link to a workaround) for the problem I was having.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.