0

I have scoured the web, including veracrypt official forums for this and nothing. It's almost like support does not exist for this issue.

When I go to mount the partition, it spits out this error: mount: /media/veracrypt1: can't read superblock on /dev/mapper/veracrypt1.

Now, in the Veracrypt GUI application, it shows it mount for a brief few seconds before spitting the error then it disappears from the list.

I own all the hardware, and use Ubuntu MATE 18.04 with no issues. I have 1 other partition not encrypted on this drive in question and it mounts perfectly fine and can be utilized. My other veracrypt partitions mounted on other drives at the same time did not experience this error as I can still mount them and utilize the drives.

I'm pretty decent with the terminal and other issues but this one baffles me.

Here's what I was doing:

1) Copying large wordlist files from this partition to my laptop.

2) The laptop completely froze.

3) I waited for 3 hours and it was still frozen.

4) No apparent I/O to the disks.

5) Held the power button down.

6) Rebooted fine.

After the reboot, I proceed to mount and it started spitting that error.

Now, I have other important files on there I'd like to get back if possible.

What I've tried:

1) Mounting via terminal but I could still use support on this

2) Force mounting and trying to recover the superblock but I can't because it will not mount the partition long enough to capture anything.

3) The GUI mounting options yet nothing worked.

4) Checked passphrases numerous times.

5) Rebooted numerous times, checked all connections.

The only relevant post is Can't read superblock with veracrypt and the OP avoided posting the solution after greedily asking for information that he resolved himself. I, however, will continue trying to make it work with diminishing returns and if I somehow figure this out, will post the solution.

Any help would be greatly appreciated.

----EDIT----

The answer supplied by "Frustrated Crypter" below is correct. It works. I managed to experience this issue except slightly different with the same storage media and it worked!!! I was able to recover the data EXACTLY as "Frustrated Crypter" described.

When Frustrated Crypter mentioned mapping it without mounting, there is a button called "Options" that expands the popup that asks for the password of the drive/partition/file you are trying to mount. In that expanded options, there is a checkbox to select that prevents it from mounting. After that, I simply right clicked on the mapped but not mounted drive/partition/file and chose Repair.. Solved all my issues right then and there.

"Frustrated Crypter", whoever you are, I'd like to buy you a beer(I'm not even lying). Message me somehow on here so I can properly thank you for your input on this matter when no one else had a guide or walk through.

1 Answer 1

2

I have fixed the issue that I was having with this after the superblock became damaged/corrupted from a system freeze and subsequent improper power off while the volume was mounted.

Basically, you aren't able to mount the volume however using Veracrypt you can click the options button in the gui to map the volume but not mount it. (the terminology may be incorrect, I am a novice.) On the filesystem options at the bottom, tick the box marked "Do not mount".

After doing so, you will see your volume on the veracrypt GUI as usual, however the mount directory section will be empty. The result should be that the partition is accessible via /dev/mapper/veracrypt#

Now we must discover which superblock backups are available within the partition.

Open a terminal and type

sudo mke2fs -n <device>

now using the information it displays,

sudo e2fsck -b  <one of the displayed options> <device>

After this you should have a working volume if your problem was the same as mine, however from here our experiences will likely diverge.

My e2fsck terminal went crazy flooding it with a mess of numbers, I don't know precisely what happened. At the end it asked if I would like to fix it, however it then said the filesystem had been changed and it was canceling its operations, however regardless the volume now mounts properly and I am able to use it without consequence.

Even though it failed this is how I discovered it was working, in a terminal I typed

sudo mount -t ext4 /dev/mapper/veracrypt# /media/veracrypt1

To my delight, it worked. I then unmounted and remounted via the Veracrypt GUI with a working result.

Best of luck. Once you understand how to access the volume without mounting it you will be able to try other options that you would typically try on a damaged partition and so will have more possible solutions to try. (Personally I had no idea I could use /dev/mapper/veracrypt# to treat it as a typical partition until a lot of troubleshooting)

*my source for the procedure I used and other possible solutions were found here https://www.quora.com/What-are-all-the-things-one-can-try-to-recover-an-ext3-filesystem-with-a-bad-superblock *

2
  • I appreciate that thank you. I will have to replicate the problem again to verify this information. Although, I was able to access the drive without mounting it. The problem is there was no way to fix the bad superblock on the encrypted partition until veracrypt decrypts it to see the filesystem. This was all weird because it's never happened before. May 28, 2018 at 19:23
  • After my edit of my question above, I have marked your response as the answer. I managed to experience this issue once again only slightly different.. Your answer worked PERFECTLY. I hope more people like you add their input on these issues which have little to no guides and walkthroughs. Thank you so much! Nov 28, 2018 at 21:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .