1

I'm running Ubuntu 18.04 on a Lenovo P50

I've tried to hibernate from the command line with sudo systemctl hibernate and what I get is

Failed to hibernate system via logind: Sleep verb not supported

And also cat /sys/power/disk

[platform] shutdown reboot suspend test_resume

Some additional information:

free
              total        used        free      shared  buff/cache   available
Mem:       15656592     4578236     8186108      183960     2892248    12247168
Swap:       2097148           0     2097148
swapon --summary
Filename                Type        Size    Used    Priority
/swapfile                               file        2097148 0   -2
0

I was getting the same error on my X1 Carbon 7th Gen. I did the following to enable the hibernation:

  1. Turn off Secure Boot in BIOS.
  2. Turn off "Modern Standby" in BIOS.
  3. Create a swap file bigger than my RAM.
  4. Update the grub using the instructions here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.