I'm running Ubuntu 18.04 on a Lenovo P50

I've tried to hibernate from the command line with sudo systemctl hibernate and what I get is

Failed to hibernate system via logind: Sleep verb not supported

And also cat /sys/power/disk

[platform] shutdown reboot suspend test_resume

Some additional information:

              total        used        free      shared  buff/cache   available
Mem:       15656592     4578236     8186108      183960     2892248    12247168
Swap:       2097148           0     2097148
swapon --summary
Filename                Type        Size    Used    Priority
/swapfile                               file        2097148 0   -2
  • Ubuntu does not support hibernate on all hardware.
    – user68186
    May 15, 2018 at 22:13
  • Have you looked at this question?
    – Hee Jin
    May 15, 2018 at 23:14
  • 1
    Possible duplicate of How can I hibernate on Ubuntu 16.04? May 16, 2018 at 5:48
  • One obvious problem is your swap space is not as big as your memory. Your swap has to be at least the same size, so your in-memory processes can be saved somewhere.
    – jpaugh
    Dec 22, 2020 at 3:35

1 Answer 1


I was getting the same error on my X1 Carbon 7th Gen. I did the following to enable the hibernation:

  1. Turn off Secure Boot in BIOS.
  2. Turn off "Modern Standby" in BIOS.
  3. Create a swap file bigger than my RAM.
  4. Update the grub using the instructions here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .