1

I bought a new laptop (Dell Inspiron 7577) and I installed Ubuntu 16.04 LTS on it. Before I did update and upgrade I tried to shutdown and reboot and it all worked properly, but after the sudo apt-get update && sudo apt-get upgrade it didn't work anymore.

What happens when I try to shutdown is: My screen just instantly freezes and I can't do anything more. Then I have to shutdown by holding the power button.

I've tried several things like:
- all different shutdown or reboot commands in the terminal (like: poweroff, reboot, shutdown -h now, halt)
- reinstalling ubuntu 18.04 LTS
- changed in /etc/default/grub the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force".

Then I tried doing a shutdown in the terminal before I logged in(Ctrl+Alt+F2). Luckily there came a output put it was also hanging. Here's the ouput:

[  125.988764] nouveau 0000:01:00.0: Xorg[957]: failed to idle channel 3 [Xorg[957]]
[  145.949670] NMI watchdog: Watchdog detected hard LOCKUP on cpu 2
[  156.293427] watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [kworker/1:1:34]
[  184.293849] watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [kworker/1:1:34]
[  185.997661] INFO: rcu_sched detected stalls on CPUs/tasks:
[  185.997908] $2-...: (1GPs behind) idle=146/140000000000000/0 softirq=4028/4128 fqs=7479
[  185.997948] $(detected by 1, t=15002 jiffies, g=1011, c=1010, q=15535)
[  212.293943] watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [kworker/1:1:34]
[  240:293901] watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [kworker/1:1:34]
[  242.857955] INFO: task kworker/u8:3:183 blocked for more than 120 seconds.
[  242.857988]       Tainted: G        W    L  4.13.0-37-generic #42~16.04.1-Ubuntu
[  242.858006] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disabled this message
[  242.858065] INFO: task systemd-logind:762 blocked for more than 120 seconds        
[  242.858083]       Tainted: G        W    L  4.13.0-37-generic #42~16.04.1-Ubuntu
[  242.858101] "echo 0 > /proc/sys/kernel/hung_taks_timeout_secs" disabled this message

Now I recently downloaded Ubuntu 18.04 and I have the exact same problem.

Could anyone help me to solve this problem?

0

How about trying old linux-kernels ? --- for example, v4.0-vivid, v4.1-wily ~ v4.5-wily

  1. Install ukuu:

    sudo add-apt-repository ppa:teejee2008/ppa
    sudo apt-get update
    sudo apt-get install ukuu
    
  2. Check the list of available kernels:

    sudo ukuu --list
    
  3. install old kernels:

    sudo ukuu --install v4.5-wily
    
  4. Remove current kernel:

    • reboot by advanced mode and choose old kernel.

    • open terminal.

      sudo ukuu --remove (current kernel)
      

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.