0

This question already has an answer here:

I am playing around with networking component of latest Ubuntu. I faced the above issue when I tried to manage networking devices with NM.

The command line output is

root@sankar:~# nmcli d s
DEVICE  TYPE      STATE      CONNECTION
eth0    ethernet  unmanaged  --
eth1    ethernet  unmanaged  --
eth2    ethernet  unmanaged  --
lo      loopback  unmanaged  --

I tried couple of solutions(comment #36 and #30) given in https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1638842.

Any help is highly appreciated

marked as duplicate by Yaron, karel, Thomas, waltinator, Eric Carvalho Jul 18 '18 at 14:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

I had this happen with an installation of Ubuntu Server 18.04 (Which uses netplan) and then adding a desktop window manager GUI (in our case, xubuntu-core^).

No Manner of re-configuring or nmcli would make these devices managed.

The solutions you tried were close, we found that if you follow the answer located here: Ethernet device not managed and note that the location of the 10-globally-managed-devices.conf is in the folder /user/lib/ you will be able to active those network devices by blanking the 10-globally-managed-devices.conf file with:

sudo mv /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf  /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf_orig

and

sudo touch /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf

And restarting network-manager or rebooting.

Not the answer you're looking for? Browse other questions tagged or ask your own question.