126

I needed to highlight some text in my screenshots and I did not know how to do it with the default screenshot app. Flameshot is a solution. I installed it.

How can I replace the PrtScr shortcut-key so that it launches Flameshot?

2
  • 1
    You should cut out everything from the second sentence onward, post it as an answer and delete it from the question so that the Q&A format is mantained.
    – dsSTORM
    May 15, 2018 at 11:47
  • Since Ask Ubuntu is a question and answer site, you should post the answer separately as @dsSTORM said. I have removed the answer part from the question, but you can find it here. Please post the answer in "Your Answer" section below. It's completely fine to answer your own question.
    – pomsky
    May 15, 2018 at 13:01

9 Answers 9

210

If you need or want to replace the PrtScr shortcut do the following:

  1. Release the PrtScr binding by this command

    gsettings set org.gnome.settings-daemon.plugins.media-keys screenshot '[]'
    
  2. Go to Settings -> Devices -> Keyboard and scroll to the end. Press + and you will create custom shortcut.
    custom shortcuts in ubuntu 18.04

  3. Enter name: "flameshot", command: /usr/bin/flameshot gui.

  4. Set shortcut to PrtScr (print).

That is it. Next time you push PrtScr flameshot will be launched.


Source: Posted in the question by OP which should have been posted as an answer instead.

8
  • 2
    You need [] inside the '' so it should be '[]'. Otherwise this should be accepted as the correct answer. Mar 17, 2020 at 22:20
  • 7
    Works in Ubuntu 20.04 Mar 8, 2021 at 21:22
  • 3
    If it's installed as a snap just set the command to flameshot gui (without the path) Apr 20, 2021 at 6:38
  • 3
    Strange that Flameshot has configuration options for a myriad of keyboard shortcuts except for the most important one.
    – Coder Guy
    Apr 26, 2021 at 18:16
  • Working in my PopOS 21.04. Thanks!
    – Akhil
    Sep 15, 2021 at 19:44
44

Install and setup flameshot via terminal ... if there is no custom0 shortcut / binding configured

Install flameshot:

sudo apt install flameshot

Release the PrtScr binding by this command:

Ubuntu 19.10 (Credits: @jobou's comment)

gsettings set org.gnome.settings-daemon.plugins.media-keys screenshot '[]'

Older Ubuntu versions:

gsettings set org.gnome.settings-daemon.plugins.media-keys screenshot ''

Set new custom binding:

gsettings set org.gnome.settings-daemon.plugins.media-keys custom-keybindings "['/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/']"

Set name:

gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ name 'flameshot'

Set command:

gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ command '/usr/bin/flameshot gui'

Set binding:

gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ binding 'Print'
8
  • 4
    On Ubuntu 19.10, I had to release the PtrScr binding with this command gsettings set org.gnome.settings-daemon.plugins.media-keys screenshot '[]'
    – jobou
    Nov 1, 2019 at 18:17
  • This worked on Fedora 31!
    – Rocky Kev
    Apr 21, 2020 at 16:51
  • Worked on Ubuntu 20.04 Mar 8, 2021 at 21:20
  • 1
    This is the Linux answer, only commands, no clicking, works. Jan 22, 2022 at 19:58
  • 1
    On Ubuntu 22.04, the binding has moved it seems. Run: gsettings set org.gnome.shell.keybindings show-screenshot-ui '[]' Aug 17, 2022 at 16:43
17

In case you installed Flameshot via snapcraft.io and not via standard sudo apt install flameshot, then the path /usr/bin/flameshot gui will not work, because the path is different.

  1. So, first run command type flameshot (for Ubuntu 18.04 and higher). This will show you the path where app is installed.

  2. Copy this path.

  3. Press Super and search for keyboard shortcut.

  4. Find word screenshot

    see this example

  5. Edit it (in my case, I assigned Shift+Ctrl+Alt+~ as I have never used this key combo)

  6. Then go back, click + symbol and add the path you have copied to command.

    and see this example

1
  • which also works as well as type, but it won't say if it's a terminal command if it is
    – mekb
    Aug 27, 2021 at 14:42
13

This is tested on Ubuntu 20.04

  1. Disable PrtScr or Print shortcut by opening the Keyboard Shortcuts Settings

  2. Navigate to Keyboard Shortcuts on bottom left menu, then select Print shortcut which is to Save a screenshot to Pictures

    keyboard shortcuts dialog

  3. Hit Backspace to disable the current keyboard shortcut so that we can use this for Flameshot later.

  4. Hit Set to apply/confirm it.

    enter image description here

  5. Identify Flame binary location with which command

    $ which flameshot
    /usr/bin/flameshot
    
  6. Then, scroll down to the bottom and select + symbol to add new shortcut.

    enter image description here

  7. Add Custom Shortcut

    • Name: Flameshot
    • Command: /usr/bin/flameshot gui
    • Shortcut: Print

    enter image description here

That's it

2
  • Also verified works on Ubuntu 22.04 May 18, 2022 at 0:34
  • @ChristianWilkie in 22.04 you can directly add the shortcut, it will ask to disable the 'old' binding. Aug 22, 2022 at 12:40
3

Or simply set any shortcut (including PrtScr) to flameshot gui: as indicated in the other answers, only without the need for any other setting. You will be asked if you want to remap the key (in Xfce at least, but I guess it's the same in most desktops).

You might consider keeping PrtScr for the default screenshot tool and use other shortcuts for flameshot, at least two I mean, because you can also capture screen with delay: for a 5-second delay, use flameshot gui -d 5000.

More here.

3
  1. Open the System Settings app and select Devices, then go to Keyboard.
  2. Scroll down to Screenshots. Select Save a screenshot to Pictures and hit delete to disable the shortcut.
  3. Then scroll all the way to the bottom and hit the plus button. Here, give it a name and type the Flameshot command you want to bind to the shortcut.
  4. Then set the shortcut as Print Screen and for command type flameshot gui.

You’re done.

1

Ubuntu 20.04:

  1. Remove the keyboard shortcut assigned for PrtScr:

    Settings -> Keyboard Shortcuts -> Click Save a screenshot to Pictures -> Press Backspace to unassign.

  2. Assign Flameshot to PrtScr:

    Press the + icon -> Name: Flameshot -> Command: flameshot GUI -> Set Shortcut -> Press PrtScr -> Click Add to save.

0

Working in Kubuntu 20.10 :

Go to System Settings

SystemSettings

Shortcuts > Global shortcuts

Settings_shotcut

click Add Application button (you can type "flameshot" on the search box)

addAplication

click OK

After adding the application, you should see a tab with Take screenshot description.

link PrtScr key to shortcut

Click on it, and press the PrtSc key on your keyboard to set the shortcut.

Enjoy :)

0

Just an update to the solution that other people wrote about already. If you did everything correct and still nothing happens when pressing the "Print Screen" button. Double check if you haven't installed flameshot via snap. If you did then command would be a bit different:

/snap/bin/flameshot gui

To find your exact flameshot location path type in terminal

type flameshot

And you should be able to see exact path to the executable you should be using as command (just add additional gui keyword behind it). Hope that helps.

Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.