6

I have a problem with all GTK apps (evince, gedit, Firefox, gimp) not seeing my installed printer. When pressing Print, I can only choose Print to file, my printer is not shown. So I can not print PDF documents, websites...

In LibreOffice, the printer works.

How can I get the printer to be seen by the apps and print PDFs?

Some more information: It is a network printer (hp). When a document is printed from LibreOffice, the printer is shown for a few seconds as printer in the other GTK apps. Then disappears again.

3

I got it solved as follows:

  1. Reinstall hplip

    sudo apt-get purge hplip
    sudo apt-get install hplip
    

    and

  2. add a second network printer. (Note that I had manually installed the newest hplip version in order to get the printer running which did not help and resulted in an error message after bootup, if you did not do this, maybe just step 2 is enough.)

    Even though there is a printer already shown in "Settings / Devices / Printers", I had to add a second printer as follows:

    1. Go to Settings → Devices → Printers.
    2. Additional Printer Settings
    3. Add Network Printer
    4. Choose the shown IP address or own printer name and follow the dialogues.

It now works for me. In the Settings → Devices → Printers tab there are now 2 printers shown.

0

Suddenly the installed Document Viewer in Ubuntu 18.04 no longer sees any installed printer, Brother or HP. After purging and reinstalling cups to no effect, I installed Okular from Ubuntu Software. It saw the printers and worked perfectly on the first try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.