7

This is the Ryzen 7 2700u version. Ubuntu 18.04 nor Ubuntu Daily will boot. What can I do? Here's the screen when I boot from Ubuntu 18.04 USB.

[0.000000] ACPI Error: [\_SB_.PCI0.LPC0.EC0_] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload-210)
[0.000000] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[0.000000] ACPI Exception: AE_NOT_FOUND, (SSDT:AmdTable) while loading table (20170831/tbxfload-228)
[0.000000] ACPI Error: 1table load failures, 7 successful (20170831/tbxfload-246)
[0.000000] [Firmware Bug] AMD-Vi: IOAPIC[4] not in IVRS table
[0.000000] [Firmware Bug] AMD-Vi: IOAPIC[5] not in IVRS table
[0.000000] [Firmware Bug] AMD-VI: No southbridge IOAPIC found
[0.000000] AMD-Vi: Disabling interrupt remapping
[0.716275] i2c_designware AMDI0010:01: Unknown Synopsys component type: 0xffffffff
[6.718168] AMD-Vi: Unable to write to IOMMU perf counter.
2
  • are you using virtual machine ?
    – user690429
    May 15, 2018 at 3:27
  • No, I'm trying to dual boot. It does however boot inside a virtual machine. May 15, 2018 at 18:54

8 Answers 8

4

I have the Ryzen 2700U Inspiron 7375 as well. I managed to get this working pretty well, however I had to get it installed using Antergos. I wasn't able to get it reliably booting under Ubuntu 18.04 unless I left acpi=off set in the kernel parameters and it wouldn't boot at all to the 4.17 kernel. I started trying different distributions and Antergos worked perfectly the first time (though I may have been lucky since afterwards it seemed 50/50).

After logs of digging and experimenting, I finally found these kernel parameters to be the key (using with linux kernel 4.17.2-1-zen from the Antergos linux-zen package):

amd_iommu=on ivrs_ioapic[4]=00:14.0 ivrs_ioapic[5]=00:00.2

Under Antergos I added these to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub then ran

sudo grub-mkconfig -o /boot/grub/grub.cfg

Now things are working pretty well! Maybe these options will help get things working under Ubuntu as well.

update: I just downloaded the 18.04 installer and tried to boot from it again (which comes with the 4.15 kernel). When I added the parameters above (by hitting 'e' on the bootloader) it was able to boot and work correctly. I didn't want to try an install over again so I didn't proceed further, but it appears to work correctly off of the live USB at least.

2
  • I'll give it a try! Jun 27, 2018 at 23:00
  • This did it! It's working exactly as I need it to now. Jun 28, 2018 at 0:13
2

Looking through Dell's supported machines, there is an exclusivity towards intel machines. I have been attempting to get the same model machine with the Ryzen5 2500u to install any Debian based OS with no success. It may be that the new AMD architecture is still being incorporated into the Kernel. Additional research is required.

I'm hoping to get more answers as the Ryzen mobile series expands in popularity across vendors. It's actually the reason I bought a new laptop; I wanted to ride the new wave as AMD rushes to the field against the old king Intel.

Update

The ubuntu shipping kernel (4.15) does not have good support for AMD Raven Ridge CPUs. Supposedly 4.16 has better support but is not actively being shipped with Ubuntu.

4
  • See this, but he updates kernels & other software to make it work or work well. Ubuntu 18.04 with updates from ppas Ryzen 7 2700 / Ryzen 7 2700X / Core i7 8700K Linux Gaming Performance With RX Vega 64, GTX 1080 Ti phoronix.com/…
    – oldfred
    May 21, 2018 at 14:41
  • It's worth pointing out that we're discussing a mobile processor unit, not the desktop variants as you linked to in the phoronix page. If we could get a base install running and update the kernel, then the OP should be good to move forward, which is what you seem to be indicating. May 21, 2018 at 14:47
  • Would it be possible for me to upgrade the kernel on my install USB before installing? May 21, 2018 at 21:43
  • There may be ways to hack the upgrade Kernel in, but you risk system instability caused by incompatibilities between the kernel version Ubuntu was designed for and the newer codes. As such, I don't have an easy process you could follow to make that occur because one doesn't really exist. I have had some success in installing Arch linux, which does support the latest Kernel OOB. May 22, 2018 at 1:48
2

Same problem on my Dell 7375. I found that removing "quiet" and "splash" and replacing with "noapic noacpi nosplash irqpoll" worked like a charm for me. It is what Linuxmint uses in the compatibilty mode. I have been able to boot both Ubuntu and Kubuntu. I intend on trying this with other distros as well, just cuz I like to play around with things.

1

Any, I said any Linux ISO images would boot on our Thinkpad E585/Ryzen 2700u. Bootline must be tweaked with iommu=soft. Otherwise, all ISO’s boot in a black screen that requires a cold shutdown.

Other ivrs arguments-tweaks would stop at Kernel 4.19.x. Kernel 4.20.x or higher would end in the same issue: Black screen.

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.0.0-050000rc7-generic root=UUID=b6976dd1-ba78-4edc-9b49-4af79a979223 ro iommu=soft quiet splash vt.handoff=1

Ryzen is at best on custom Kernel, without internal pollution of old machines.

All the best,

sudo -i gedit /etc/default/grub

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=false         ►**To Boot in Grub Menu**
GRUB_TIMEOUT=                    ►**For 5 Seconds**
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="iommu=soft"  ►**To Boot ISO Images And Custom Kernel**

Ryzen, bootline, iommu=soft, black screen, thinkpad E585, e terminal,ubiquity

Edit: Never seen the desktop of OpenMandriva Lx, Manjaro, Antergos,, lost desktop of Mageia after first updates. Not to mention all distros not compatible with Secure Boot.

2
  • Did you try "amdiommu=on" instead of "iommu=soft"? Feb 21, 2019 at 14:19
  • amdiommu=on: Not working, freezes at Loading Initial RAM Disk. Tumbleweed build 20190209. iommu=soft is the only argument that allows machine to compile custom Kernel. Thanks for the tip. Feb 21, 2019 at 15:55
0

I've been working on my own Inspiron 7375, and I've run through several distros that all failed in one way or another (certainly, some may have been my fault, but I didn't catch them if it was). Then I got Ubuntu 16.04 to work, with the 4.15 kernel, so I tried 18.04.

Wouldn't work. I fiddled around and tried adding acpi=off to the kernel arguments. Ta da! Worked. Brought up everything, seemed to work well. After I installed everything, however, I found that the system didn't recognize the monitor(while still writing to it reasonably well), and that it only recognized one of the eight CPU cores. Back to more fiddling.

Where I'm at now is that I've changed the default arguments from "quiet splash" to "pci=noacpi splash" . This seems to work, when I run it, most of the time it comes up fine.

Hope that helps.

Now I'm finding that it boots right when I boot it to Windows, reboot from there, and go into Ubuntu. So the Windows shutdown sequence seems to be resetting something that allows the linux display setup to work. I don't know what.

4
  • I'll try this when I can, my laptop's out of commission right now. May 30, 2018 at 0:51
  • I wasn't able to boot with "pci=noacpi", did you add that to the installer, or did you copy a partition over? Jun 3, 2018 at 20:53
  • I installed with "acpi=off" I added "pci=noacpi" to the grub boot selection via /etc/default/grub, then running update-grub.
    – DeacBlue
    Jun 8, 2018 at 1:30
  • No dice for me :( Jun 10, 2018 at 21:48
0

I have run into the same issue I put noapic in the kernel boot options. I don't think it's an APCI issue directly. I think it's something with interrupts and sleeping cores and the kernel not being able to wake up the cores. If you take out quiet and splash you can see more detail.

0

Adding a new answer, as even if you get install to work - boot seems very unreliable. I have tried the very latest Ubuntu 19.04 pre-release (2019-02-20 updates) and Ubuntu 18.10 - and it consistently freezes / lock-up during boot.

To get install and boot to work at all, common advice for this Dell 7375 is to start with:

amd_iommu=on ivrs_ioapic[4]=00:14.0 ivrs_ioapic[5]=00:00.2

I tried hundreds of boots, and almost always from a cold boot (at least 10 seconds off to let RAM drain). No matter what, I would be lucky to get 1 boot out of 3 all the way past login. Sometimes the graphics would start very slow and cursor would appear in bottom right, but the login screen not draw, but more often than not it would hang before even getting into graphics / login prompt.

Also be sure to grep your dmesg and check your BIOS level. In all these Ryzen Vega Linux issues, from any vendor of laptop, BIOS is cited as the main cause for all these problems. So make sure we are all starting with the most recent. The latest avaialble I found was (from my dmesg):

Dell Inc. Inspiron 7375/0GTNWX, BIOS 1.5.0 07/09/2018

I suggest you remove both splash and quiet from GRUB so you can see where things are hanging. And what I noticed is that every time it worked, the framebuffer driver would change about 1/3 through the console messages (dmesg). But the failed attempts did not clear the screen during boots.

This proved to be a key clue, as I found a user running Slackware 14.2 who focused on that console boot issue on this exact model laptop. I ended up with less-mentioned information here: https://www.linuxquestions.org/questions/slackware-14/amdgpu-raven-screen-freeze-on-switch-from-efifb-to-amdgpudrmfb-4175636284/

Which focused on the console frame buffer driver (amdgpudrmfb) only working some of the time. Then I changed my /etc/default/grub to have:

GRUB_CMDLINE_LINUX_DEFAULT="amdiommu=on ivrs_ioapic[4]=00:14.0 ivrs_ioapic[5]=00:00.2 acpi_backlight=vendor nomodeset vga=normal"

And now my system boots every single time!

2
  • Still erratic and unpredictable, but not hard freeze and lockup. Some boots you will get a rapid blinking cursor at upper left on a blank screen before login appears. Try pressing Ctrl+Alt+Fn+3 wait 5 seconds (you will get a console login prompt, ignore it), then Ctrl-Alt-Fn+1 to go back to the blank-cursor-only screen. Doing this 2 or 3 times then gets the login to start. Feb 21, 2019 at 14:16
  • Found a useful reference page specific to this laptop: wiki.archlinux.org/index.php/Dell_Inspiron_7375 Mar 13, 2019 at 21:13
0

I hope this helps some of you in the same boat I was in.

to boot the live usb I initially had to use COMPATIBILITY MODE dell 13 7375 AMD RYZEN 2500U

Kernel: 5.3.0-51-generic x86_64 bits: 64 compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin dm: LightDM Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic

same boot issues and the following info helped me greatly. As i am on Linux Mint 19.3 now that I took these steps.

Thanks to the folks at:

https://forums.linuxmint.com/viewtopic.php?t=220493

At boot up of GRUB I Press E key to bring up options screen,

then on the line of text that starts with the word Linux I type:

noapic noacpi nosplash irqpoll

I replaced the text that reads "squiet splash".

This got me in to do updates and it restarted without fuss after that.

1
  • No pinch to zoom yet for touch pad or touch display May 6, 2020 at 10:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .