4

I am using Ubuntu 16.04 LTS and I ran do-release-upgrade -d but the upgrade failed with an error message saying packages have unmet dependencies.

sudo apt-get -f install also failed to fix the errors.

Here is the full error message:

Correcting dependencies... failed.

The following packages have unmet dependencies:

 checkbox-converged : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable
 gnome-calendar : Depends: gsettings-desktop-schemas (>= 3.21.2) but 3.18.1-1ubuntu1 is installed

 gnome-session : Depends: gnome-shell (>= 3.25.91-0ubuntu4~) but it is not installed

                 Depends: gnome-session-bin (>= 3.28.1-0ubuntu2) but 3.18.1.2-1ubuntu1.16.04.2 is installed

                 Depends: gnome-session-common (= 3.28.1-0ubuntu2) but 3.18.1.2-1ubuntu1.16.04.2 is installed

                 Depends: xwayland but it is not installed

                 Recommends: fonts-cantarell but it is not installed

                 Recommends: adwaita-icon-theme-full

                 Recommends: gnome-themes-extra but it is not installed
 gnome-settings-daemon : Depends: libgnome-desktop-3-17 (>= 3.17.92) but it is not installed
                         Depends: gsettings-desktop-schemas (>= 3.20) but 3.18.1-1ubuntu1 is installed

 libc-dev-bin : Depends: libc6 (< 2.24) but 2.27-3ubuntu1 is installed

 libc6-dbg : Depends: libc6 (= 2.23-0ubuntu10) but 2.27-3ubuntu1 is installed

 libc6-dev : Depends: libc6 (= 2.23-0ubuntu10) but 2.27-3ubuntu1 is installed

 libqt5quick5 : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed

                Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed

                Depends: libqt5qml5 (>= 5.9.5) but 5.5.1-2ubuntu6 is installed

                Depends: qtbase-abi-5-9-5

                Depends: qtdeclarative-abi-5-9-5

 libunity-webapps0 : Depends: unity-webapps-service but it is not installable
 libwayland-egl1-mesa : Depends: libegl1 but it is not installed

 qml-module-qtquick-controls : Depends: libqt5qml5 (>= 5.9.5) but 5.5.1-2ubuntu6 is installed

                               Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed

                               Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed

                               Depends: qtbase-abi-5-9-5

                               Depends: qtdeclarative-abi-5-9-5

 qml-module-qtquick-dialogs : Depends: libqt5qml5 (>= 5.9.5) but 5.5.1-2ubuntu6 is installed

                              Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed

                              Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed

                              Depends: qtbase-abi-5-9-5

                              Depends: qtdeclarative-abi-5-9-5

 qml-module-qtquick-window2 : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed

                              Depends: qtdeclarative-abi-5-9-5

 qml-module-qtwebkit : Depends: libqt5core5a (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed

                       Depends: qtdeclarative-abi-5-9-5
 qml-module-ubuntu-test : Depends: qml-module-ubuntu-components but it is not installable

                          Depends: libubuntugestures5 but it is not installable

 qml-module-ubuntu-ui-extras-browser : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin (>= 1.3) but it is not installable or

                                                qtdeclarative5-ubuntu-ui-toolkit-plugin-gles (>= 1.3) but it is not installable

 qml-module-ubuntu-web : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin (>= 1.3) but it is not installable or

                                  qtdeclarative5-ubuntu-ui-toolkit-plugin-gles (>= 1.3) but it is not installable

 unity-control-center : Depends: libgnome-desktop-3-17 (>= 3.27.90) but it is not installed

                        Recommends: system-config-printer but it is not installed

                        Recommends: gnome-control-center-faces but it is not installed

 unity-webapps-qml : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable or

                              qtdeclarative5-ubuntu-ui-toolkit-plugin-gles but it is not installable

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

E: Unable to correct dependencies

In addition, the GUI got somewhat strange.

What has happened?

  • What is the output of sudo apt-get install -f? – fosslinux May 14 '18 at 23:06
  • @ubashu: sudo apt-get install -f gives almost the same output ! – Oualid May 15 '18 at 6:18
  • What happens when you run sudo apt-get update && sudo apt-get upgrade? – fosslinux May 15 '18 at 6:24
  • The same thing. It does not launch the update but shows me dependencies error! – Oualid May 15 '18 at 6:26
  • How many PPAs do you have in your system? – N0rbert May 15 '18 at 7:06
3

This worked for me:

Open a terminal with: CTRLALTF1 (enter your user and password) then

sudo apt install aptitude

next step

sudo aptitude install ubuntu-desktop gdm3

you will be offered options how to fix the incompatibilities, hit a few times N and ENTER until you are suggested with some removal of old packages and installing of updated one.

then give Y and ENTER to a solution that removes old incompatible packages and installs the new ones.

last

sudo reboot

The above worked for me.

  • Why not a straight forward sudo apt install ubuntu-desktop gdm3? – WinEunuuchs2Unix Jul 27 '18 at 0:41
  • 1
    @WinEunuuchs2Unix apt will not work it says it needs dependencies but will not install them, like this Depends: x but it is not going to be installed – Eduard Florinescu Jul 27 '18 at 6:51
  • 1
    The dependency issues are interesting. – WinEunuuchs2Unix Jul 27 '18 at 10:57
2

Open a terminal using CTRL-ALT-T and type:

update-manager -cd

From here, try to update. If there is an error with an option that says partial upgrade, click it. This will restore the GUI. Reboot, and run the command again. There should be no error, and you can proceed with the upgrade via the GUI.

  • 1
    the update manager does not launch anymore, stuck at the starting. – Oualid May 15 '18 at 6:21
2

You seem to have got a number of broken packages, as per the error message E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.. To resolve, look at the file /var/log/dist-upgrade/apt.log. Locate the packages that are broken and remove them with sudo apt-get remove broken-package. If there are dependency errors, then try to reinstall the package: sudo apt-get install --reinstall broken-package.

Now try fixing dependency errors:

sudo apt-get -f install

Reboot and try upgrading again.

  • it does not work ! file /var/log/dist-ypgrade/apt.log does not even exist! I get the same error message – Oualid May 16 '18 at 6:08
  • Not /var/log/dist-ypgrade/apt.log, /var/log/dist-upgrade/apt.log. Does that exist? – fosslinux May 16 '18 at 6:46
  • it's a typo. No, it doesn't exist ! – Oualid May 16 '18 at 18:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.