0

Our office uses Windows Server 2003. Fourteen client PCs use Windows (7, 8.1 & 10) plus 10 more client PCs use Ubuntu 16.04 LTS.

Linux users have issues in accessing data from server. Some files (.docx/.xlsx/.odt/.ods) open as read only from within LibreOffice 6 and WPS Office 2016, and since users are unable to make changes in those files, they must create another copy of the files... they get the user permission error.

Error saving the document- The Object cannot be accessed due to insufficient user rights. 

The client PCs are connected through LAN and we are accessing the server through SAMBA.

Also if any file is created by Linux users, and any Windows user is trying to access it, it also opens read-only.

In some folders they are unable to rename the files or they can't paste the data or they are unable to delete files.

The smb.conf information is given below:

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
    server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = yes
>Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares. This will share each
# user's home directory as \\server\username
;[homes]
;   comment = Home Directories
;   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# Un-comment the following parameter to make sure that only "username"
# can connect to \\server\username
# This might need tweaking when using external authentication schemes
;   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
  • "due to insufficient user rights" what you need to do is check the GROUP setting. Windows creates the files with the settings from smb.conf. If those do not match you get a permissions error. I would assume windows creates it with a different group than your Ubuntu users. You will need to put them all in the same group – Rinzwind May 14 '18 at 12:25
  • Rinzwind, can you please let me know, where do I check this, and what should be the ideal settings to run the system properly. – ssbdelhi May 14 '18 at 12:27
  • is there anyone who can tell me what changes should I make in smb.conf to resolve this error. – ssbdelhi May 16 '18 at 8:33
  • @ssbdelhi we don't even know what your smb.conf looks like at the moment. How do you suppose we should propose changes? – 0xC0000022L May 24 '18 at 19:09
  • Is the 'Samba' configuration you use just the 'smbclient' on the Linux PCs? Or does a Linux machine use more of the Samba suite and actually provide services? – K7AAY May 24 '18 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.