0

Recently installed Ubuntu 18.04 after the automatic upgrade from 17.10 failed, resulting in my inability to turn on the system normally. After installing the OS the brightness controls on my laptop has stopped working. There are no brightness controls in the settings either in the new OS either. How can I get it to work?

  • Why did you double Post the same Issue? askubuntu.com/questions/1036039/… – EODCraft Staff May 14 '18 at 10:12
  • 1
    that question is for the existence of a brightness bar that should be there so that even if I don't have buttons I can change the brightness. I noticed that because my brightness control buttons were not working either(which is what this question is about) – akabhirav May 14 '18 at 10:14
  • I believe it's the same issue...Our Hardware (or at least as far as 18.04 is concerned) doesn't support brightness settings. – EODCraft Staff May 14 '18 at 10:47
  • 1
    seems so, but as I said in my other question, does not make sense as both brightness controls and brightness buttons worked in 17.10 for the same computer – akabhirav May 14 '18 at 10:48
  • Related questions: askubuntu.com/a/715310/307523 and askubuntu.com/q/1045624/307523 – WinEunuuchs2Unix Jun 14 '18 at 23:29
0

If you are referring to the keys to change brightness up and down (in my laptop it is Fn+F11/F12):

I am running Xubuntu 18.04 and have struggled with the impossibility to control brightness using the Fn+F11/F12 keys since I installed it...

I just found out an option in the Power Management section, "Handle display brightness keys", which by default came deactivated. I just turned it on and the Fn+F11/F12 keys work as expected.

Perhaps there is a similar option in the Power Management section for Ubuntu vanilla and other flavors.

  • Sadly, I don't have my computer with me right now. I will check and reply as soon as my computer comes back. – akabhirav Jun 10 '18 at 7:47
0

On Xubuntu 18.04 (Ubuntu with xfce desktop) my brightness problem finally solved.

I opened 'Onboard Settings' under the 'Settings' menu. If your desktop doesn't have one, you can download it from Software Center.

On the 'Onboard Preferences' window, click the Layout menu, then choose the 'Full Keyboard' (Desktop keyboard with edit and function keys). Click here to view the Onboard Settings window

protected by Community Jan 30 at 11:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.