7

I like the old-good Software Sources interface (some sources are seen only there in fact), but it looks absent in Kubuntu 18.04 (cannot find it in the launcher anyway).

I remember that in Ubuntu 18 Gnome/Budgie was absent but I was able to install it back.

How to get it back in Kubuntu 18.04?


Posted in order to provide an answer.

3

The .desktop file for Software Sources is /usr/share/applications/software-properties-kde.desktop in Kubuntu 18.04 but if you open the file with a text editor, you'll see a line with:

NoDisplay=true

One can comment out that line (and do so each time the package is updated). Alternatively, one could copy over the .desktop file over to ~/.local/share/applications and make the change in the copied file.

Whichever way is chosen, Software Sources can be seen in the launcher under System:

Launcher

Or, it can be accessed via krunner:

Krunner

Either way, when launched, you'll be prompted for your user password.

To find a clue as to why this application's .desktop file has NoDisplay by default, I ran apt-get changelog python3-software-properties > sof-pro-kde.txt. In there, way back in Karmic Koala, there is this:

software-properties (0.75.4) karmic; urgency=low

  * Suffix software-properties.desktop with -gtk.desktop
  * Create a copy of that file with suffix -kde.desktop
    + Change to KDE icon and exec
    + Add NoDisplay=true, the desktop file is only necessary for kdesudo to 
      have it show a proper name and icon which does not require it to show
      up anywhere
  • kate /usr/share/applications/software-properties-kde.desktop also allows to have it changed – user47206 Jun 27 '18 at 15:20
  • 1
    True, but if kate is updated as it probably will if you install the kubuntu-backports ppa you'll need to make that change each time. That's why I prefer editing a local copy. Note that the kubuntu-backports ppa doesn't yet have new stuff like plasma 5.13 for Bionic. – DK Bose Jun 27 '18 at 15:42
  • on plasma 5.13: tested it in Neon itself and even there kwin crashed after a few minutes. No way I'll install that in Kubuntu after all. – user47206 Jun 27 '18 at 15:59
  • For some reason adding new key doesn't work: NameError: name 'KUrl' is not defined - askubuntu.com/q/1079793/47206 – user47206 Sep 30 '18 at 19:09
6

It is already installed but is not seen by the launcher by default. In order to make it visible, follow the other answer posted by DK Bose.

It can be launched with the command

sudo -H software-properties-kde

as suggested in a comment by @DKBose

Or, through the Kubuntu's Software -Center (Discover), clicking Settings and the upper-right button

enter image description here

enter image description here


After having installed LXQT desktop (on top of Kubuntu), what I prefer now is to use the lxqt-sudo tool in the Exec line of the .desktop file /usr/share/applications/software-properties-kde.desktop.

Exec=lxqt-sudo software-properties-kde

which shows the window with Qt-GUI (the Qt widget style of KDE/LXQT set under the LXQT settings) instead of GTK.

enter image description here

It seems that lxqt-sudo has that effect only in LXQT, and not in KDE/Plasma.

  • 3
    sudo -H software-properties-kde maybe preferable to sudo software-properties-kde since it's a graphical application. – DK Bose May 14 '18 at 10:27
  • 1
    @DKBose - thanks for pointing it out: it's in the answer now. – user47206 May 14 '18 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy