38

In htop F10 is used to exit but it conflicts with Terminal function to show menu instead.

How can we unbind F10 in terminal?

56
  1. Edit -> Preferences -> General:

  2. Uncheck "Enable the accelerator key (F10 by default)"

Terminal settings

If this is the only conflict you could also use Ctrl + c or just q to quit htop.

6
  • 7
    Seems baffling that this isn't under Shortcuts...
    – Will S
    Aug 1 '18 at 16:20
  • 11
    Seems even baffling that this is a default setting for a linux terminal. Nuts.
    – Íhor Mé
    Aug 27 '18 at 17:11
  • 2
    you saved my day!
    – makerj
    Aug 16 '19 at 8:06
  • 2
    Finally I can start using Midnight Commander properly.
    – mono68
    Jan 13 '20 at 14:20
  • 1
    I hate this default, and I am among the first to set it up on every install - ubuntu 18.04 and 20.04
    – sarki_roka
    Oct 23 '20 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.