Today I was facing the issue that videos (YouTube and other sites) in Chrome and Firefox won't start playing (I can jump around single frames inside the videos by clicking in the timeline) while it was working fine until earlier today.

I'm running Ubuntu 18.04 on a DELL M3800 (Nvidia GPU).

I tried uninstalling nvidia-340 and now I'm no longer able to login to "Ubuntu" but only "Ubuntu on Wayland" at login screen.

Re-installing nvidia-340 or installing nvidia-390 didn't fix it.

When choosing "Ubuntu" the screen turns black for a second and then returns back to the login screen me being logged out again.

Update: I tried to set nomodeset in GRUB but this didn't fix it.

Update 2: sudo ubuntu-drivers autoinstall didn't fix it neither.

Update 3: uncommenting #WaylandEnable=false and re-commenting it in /etc/gdm3/custom.conf seems to have fixed the login loop. But now I'm now longer able start terminal. Mouse turns into a spinner for a few seconds but terminal is not starting.

Update 4: dbus-launch gnome-terminal launches terminal after I ran sudo chown username.username -R .dbus

Update 5: This answer fixed my broken terminal (and by reading the answer I noticed Nautilus was broken as well).

Update 6: Fix from Update 5 is not permanent.

Update 7: switching back to bash from zsh fixed the terminal/nautilus issues permanently. But I'm still not able to play videos and I'm not able to install any of the Nvidia drivers.

Update 8: Update 7 was not permanent.

1 Answer 1


I partially solved the issue doing this:

  1. dpkg-divert --list | grep nvidia-340 to show all nvidia-340 dependecies
  2. For all of them I did dpkg-divert --remove *path*
  3. apt --fix-broken install
  4. apt update
  5. apt upgrade
  6. ubuntu-drivers devices
  7. ubuntu-drivers autoinstall Then reboot. In case the screen resolution is lower than possible follow this tutorial

Hope you'll solve.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .