I've got a new laptop which is Lenove's E420s. And I have encountered a big problem that I can't make the fingerprint reader work properly.

I've also tried fingerprint-gui. But unfortunately, it's told that "No Device Found". Here is my screenshot: http://ge.tt/98Xg2WD/v/0

It's said that 147e:1002 is supported by fingerprint-gui on the official website.

So, I'm curious about the situation. Anybody knows?

P.S: I'm using gentoo, but I think this problem may not have anything to do with distribution since I compiled the source from official site.


I have the same device in my System 76 Serval. fprint_demo, fingerprint-gui, fingerprint-identifier will only recognise my fingerprint reader when I run them with gksudo.

I suspect it needs a udev rule created for it in order to run properly.

  • good explanation! But it does not work here using gksudo..T_T – ymfoi May 19 '12 at 2:45
  • In my case it was actually because my user account wasn't in either of the following user groups : scanner, usbdev. – airtonix May 19 '12 at 17:38

I have the exact same fingerprint reader (147e:1002 Upek unknown device) and have the problem as you've described - that it does not recognise the device.

Despite this, I've found that fingerprint GUI still works - that you can scan in your fingerprint and use it as the program intended, although it is currently not officially supported by fprint. You have to install libbsapi driver.

  • How can I scan in my fingerprint in the case that those functional tabs are gray? – ymfoi Jul 20 '12 at 13:29
  • Do you have the same fingerprint reader? – Charlie Aug 9 '12 at 0:04
  • my id is 147e:1002, is that the same as yours? – ymfoi Aug 10 '12 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.