3

I just created a persistent live USB of ElementaryOS on a 32GB USB stick by following this awesome guide.

The problem is that mkusb should let you use the remaining space as an usual storage USB stick as stated in the community wiki:

The rest of the drive space is used for storage compatible with Windows

... the problem is that it doesn't, Windows 10 sees that FAT32 partition as unusable and asks me to format it. The Windows's disk management tool is not able to format it, change letter or anything else (though it correctly show me the partitions that mkusb has created in the USB drive).

I tried also on OSX and on ElementaryOS and I have no issues there, I can correctly mount, read and write in the storage partition.

  • elementaryos.stackexchange.com – user772253 May 14 '18 at 5:07
  • 1
    my problem is more linked to mkusb, that’s why I’m asking here – Oneiros May 14 '18 at 5:29
  • 3
    I will look into the problem, and to be successful I need some information from you. [To begin with] I ask for the linux distro (Elementary?) and version, where you have installed Ubuntu. If this is considered off-topic here, I suggest that you post a reply at this thread at the Ubuntu Forums, and we can continue the dialogue there. – sudodus May 15 '18 at 9:03
  • Hello @sudodus, thank you for yuor response and thank you for mkusb, it is a fantastic tool! I followed the procedure from a live installation of Elementary OS 0.4.1 Loki and I installed the very same version of Elementary OS on a second, bigger usb stick using mkusb. I tried it again but no luck, Windows sees the big partition as unusable – Oneiros May 17 '18 at 19:20
  • Which big partition is unusable? Partition #1 with the NTFS file system and the label usbdata? It should be readable and writable by Windows. But partition #5 with the ext4 file system and the label casper-rw can not be managed by Windows, or should we say, Microsoft does not want to recognize linux file systems. – sudodus May 17 '18 at 19:32