8

I installed ubuntu 18.04 few days after the release. It was working fine until now. Now it is not detecting the external monitor.

My system a Laptop MSI gs30 2m shadow without external dock:

$ lsb_release -a :

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04 LTS
Release:    18.04
Codename:   bionic

$ sudo lspci -v:

00:02.0 VGA compatible controller: Intel Corporation Crystal Well Integrated Graphics Controller (rev 08) (prog-if 00 [VGA controller])
    Subsystem: Micro-Star International Co., Ltd. [MSI] Crystal Well Integrated Graphics Controller
    Flags: bus master, fast devsel, latency 0, IRQ 34
    Memory at afc00000 (64-bit, non-prefetchable) [size=4M]
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 5000 [size=64]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915
    Kernel modules: i915

$ xrandr :

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 294mm x 165mm
   1920x1080     60.00*+  59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1440x900      59.89  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1360x768      59.80    59.96  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      60.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       60.06  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  

I don't have a clue why is happening:

  • The only error on the XOrg logs is (EE) open /dev/fb0: Permission denied ($ grep EE ~/.local/share/xorg/Xorg.*)
  • Also, on display settings, there is no "Detect Displays" button, like in Ubuntu 17.10.
  • I tried installing latest drivers from https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers
  • I tried with different cables and monitors.
  • Googling, I didn't find any recent response that fit with my problem.
  • Tested cable and monitor with other laptop and working without any issue.
  • Tested with Live USB and working without issues.
  • Both monitor working in the Login.
  • Is the module i915 the right one for an i7-4870HQ (Haswell microarch)?

To be honest, I don't know where to start to search.

Note: In the office is working as usual with two monitors!! It is like if it's memorizing the configuration. But las week dual monitor was working at home. What did change? How to fix it?

  • With the external monitor plugged in. Open the terminal and run xrandr. Then copy and paste the output into your question. Thanks. – WinEunuuchs2Unix May 13 '18 at 14:24
  • @WinEunuuchs2Unix Added xrandr. I guess that it is the integrated display. Is useful the full response or can I remove the list of resolutions from the answer? – angelcervera May 13 '18 at 14:56
  • Yes it is the integrated display. Your external display should show up as DP-1 Disconnected. Strangely there is no line at all for it. As far as removing the various resolutions you can replace them all with a ... if you like. – WinEunuuchs2Unix May 13 '18 at 15:00
  • Yes, no present. And the same issue using other monitors and cables. No errors, no logs, ... nothing. – angelcervera May 13 '18 at 15:06
  • Could you try that? unix.stackexchange.com/questions/315169/… I don't know if it will work, but I hope so. – Marcelo Loureiro Dec 3 '18 at 12:03
0

When I tried:

  • Cable and monitor tested with other laptops with no issues.
  • Laptop tested with other monitors and only working with the one that I'm used to using in the office.
  • Boot using the Ubuntu 18.04 Lived USB works.
  • Login page enables the second monitor. It is after login when it stops to work.

So the problem it is clear that the problem is with my user.

Step to solve the problem:

  • Remove (or move) the ~/.local/xorg folder
  • Restart.
  • Now, the monitor is not working but at least it is in the Display setting so it is detected. Then, I can enable it and configure as second monitor.

So it is fixed. Also working in the office with the other monitor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.