I am having some issues with Packet Tracer 7 on Ubuntu 18.04: when I launch it with ./PacketTracer7 within the /opt/pt/bin directory, it opens but close immediately with a lot of:

"Warning: libpng warning: iCCP: known incorrect sRGB profile"

error msgs on the console.

The thing is, I installed PacketTracer7 on Ubuntu 16.04 and I remember that I had that issue with the libqt5multimedia.so.5 dependency, but I was able to find the solution (thanks to askubuntu and google) by installing the dependencies. So, everything perfect with 16.04.

But I'm a bit lost now. I can't realize where the issue come from, because I know the qt5 libs are installed on the system.

This is what I see when I run dpkg --get-selections:

libqt4-xmlpatterns:amd64            install
libqt5concurrent5:amd64             install
libqt5core5a:amd64              install
libqt5dbus5:amd64               install
libqt5gui5:amd64                install
libqt5multimedia5:amd64             install
libqt5multimediaquick-p5:amd64          install
libqt5multimediawidgets5:amd64          install
libqt5network5:amd64                install
libqt5opengl5:amd64             install
libqt5opengl5-dev:amd64             install
libqt5positioning5:amd64            install
libqt5printsupport5:amd64           install
libqt5qml5:amd64                install
libqt5quick5:amd64              install
libqt5quickparticles5:amd64         install
libqt5quicktest5:amd64              install
libqt5quickwidgets5:amd64           install
libqt5script5:amd64             install
libqt5scripttools5:amd64            install
libqt5sensors5:amd64                install
libqt5sql5:amd64                install
libqt5sql5-sqlite:amd64             install
libqt5svg5:amd64                install
libqt5test5:amd64               install
libqt5webchannel5:amd64             install
libqt5webkit5:amd64             install
libqt5webkit5-dev:amd64             install
libqt5widgets5:amd64                install
libqt5x11extras5:amd64              install
libqt5xml5:amd64    

I've tried to uninstall pt and the qt5 libs and install everything again, but nothing... the same issue.

Did anybody install PacketTracer7 on Ubuntu 18.04?

I would be very happy to have your help for doing it!

Thanks and forgive me for my poor english :)

up vote 7 down vote accepted

These are the steps that worked for me in order to make Packet Tracer work in Ubuntu 18.04:

  1. Install the Qt libraries with apt-get:

    sudo apt-get install libqt5webkit5 libqt5multimediawidgets5 libqt5svg5 libqt5script5 libqt5scripttools5 libqt5sql5
    
  2. Install libcu52:

    wget http://mirrors.kernel.org/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.8_amd64.deb
    sudo dpkg -i libicu52_52.1-3ubuntu0.8_amd64.deb
    
  3. Install libpng121:

    wget http://ftp.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb
    sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb
    

Now you can start Packet Tracer with the packettracer command.


1 Thank you, gitgudgithub, for pointing that out.

  • Muchas gracias Lucas! I did follow your steps and packettracer now is working fine! However I don't know exactly what was the problem, because I know that those libraries were already installed on my Ubuntu, I did it many times before. But the good thing is that I just made copy/pasete what you wrote and now it's working. Maybe I was doing something wrong before. Thanks a lot! – Julian Carrizo May 20 at 22:14
  • for libicu52 is it a problem to have newer versions installed? – Thufir Jul 7 at 11:42
  • Worked for me! Thanks a lot! – Philippe Delteil Nov 12 at 21:43

I was in the same boat. After Googling three days I figure out that a lot of libraries are missing or not available in correct path.

Following libraries are not installed in correct path

libQt5WebKitWidgets.so.5, libQt5WebKit.so.5, libQt5Multimedia.so.5, libQt5PrintSupport.so.5, libQt5Svg.so.5, libQt5Widgets.so.5, libQt5Gui.so.5, libQt5Network.so.5, libQt5Xml.so.5, libQt5Script.so.5, libQt5ScriptTools.so.5, libQt5core.so.5

Following libraries have been replaced with updated version in Ubuntu

libicui18n.so.52 and libicuuc.so.52

Following library is missing

libpng12.so.0

The correct way to install and fix this issue is following

access root shell prompt and install packet tracer normally

$sudo /bin/bash
#./install

view image for screenshot

run following command

#chmod +x set_ptenv.sh
#chmod +x set_qtenv.sh
#./ set_ptenv.sh
#./ set_qtenv.sh
#cp /opt/pt/lib/libQt5* /usr/lib/x86_64-linux-gnu
#wget http://launchpadlibrarian.net/341176988/libicu52_52.1-3ubuntu0.7_amd64.deb
#dpkg –i libicu52_52.1-3ubuntu0.7_amd64.deb
# updated
#cp /etc/apt/sources.list /etc/apt/sources.list.bak
#echo “deb http://mirrors.kernel.org/ubuntu/ xenial main” >> /etc/apt/sources.list
#apt-get update
#apt-get install libpng12-0

view image for screenshot

After system restart run packet tracer with packettracer command

view image for screenshot

Source https://www.computernetworkingnotes.com/ccna-study-guide/how-to-install-and-start-packet-tracer-in-ubuntu.html

I think you have installed all the needed libraries for Packet Tracer.

Now do the following, that may fix your problem:

  1. sudo mkdir /opt/pt/libwebkit
  2. sudo cp /opt/pt/lib/libQt5WebKit.so* /opt/pt/libwebkit
  3. Then start Packet Tracer with: sudo LD_LIBRARY_PATH=/opt/pt/libwebkit/ /opt/pt/bin/PacketTracer7

It should give you some error messages that some libraries are not found. I had to install libpng12 and libqt5sql5.

libpng12 here: https://packages.debian.org/de/jessie/amd64/libpng12-0/download

libqt5sql5 with apt: sudo apt install libqt5sql5

After that run PacketTracer in /opt/pt/bin, it will crash and give you an error. Then just run packettracer in a terminal, it should work now.

Hopefully this will help you run Packet Tracer 7 in Ubuntu 18.04 :)

  • Thanks for your response @gitgudgithub! I did that, and had to install some other libraries too but, at the end, PacketTracer crashes. Sometimes it opens but it still freeze for some seconds, and close agains with the Segmentation fault msg. Perhaps it's an issue with Ubuntu 18.04. Were you be able to run PacketTracer on 18.04? – Julian Carrizo May 13 at 22:46
  • hm, it worked for me. You should try to contact cisco :) – gitgudgithub May 15 at 5:54
  • A friend told me today that you have to install Qt with all its libraries from here: qt.io/… and then download + install Packet Tracer. – gitgudgithub May 15 at 19:29
  • You'll also need Qt4: download.qt.io/archive/qt/4.8/4.8.6 – gitgudgithub May 16 at 13:38
  • Thanks for you help gitgudgithub! I finally solved the issue thanks to you and Lucas! I thnik that I did something wrong when installing some libraries. I did everything again and now it's working!! – Julian Carrizo May 20 at 22:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.