28

I have a Dell XPS 15-9560 laptop with 15.6" 4K Ultra HD (3840 x 2160) IGZO IPS 350-nits Touch-screen, and NVIDIA GeForce GTX1050 4GB GDDR5. It's having 4K resolution. Right from the grub screen to Ubuntu, it's having very very small fonts. Is there any way i can increase the fonts size?

This is a real nice laptop - real MacBook Pro killer..getting very popular...and i can see a lot of folks will be having the same issue.

Edit 1

I messed up my current installation of ubuntu desktop 18.04 LTS and have to reinstall it all over again. Just tried this one now: Adding nouveau.modeset=0 to the boot parameters was much better workaround for smaller fonts and i am having much better resolution now. It's much better solution than others as of now.

Seems to ubuntu18.04 LTS is not as stable and much more complex issues with Nvidia graphics card than the previous versions.

  • You can tell Ubuntu to scale its display elements in settings. – Thorbjørn Ravn Andersen May 13 '18 at 11:49
  • Please tell me the steps in terms of how?? – Ashu May 13 '18 at 14:08
  • 2
    I believe @ThorbjørnRavnAndersen is referring to bottom answer here of using Settings -> Displays. – WinEunuuchs2Unix May 13 '18 at 14:17
26

You may use (GNOME) Tweaks to adjust font sizes of various elements. First install Tweaks by running

sudo apt install gnome-tweaks

(or sudo apt install gnome-tweak-tool).

Then launch Tweaks and go to the Fonts section, you'll get the options to change font sizes.

enter image description here

  • 1
    This worked...i was making the changes from the root user Not from the logged in user. Worked fine. – Ashu May 13 '18 at 23:00
  • But still the fonts at Grub Screen - overall ICONs are bit tiny..not everything is being scaled up. Any idea for that? – Ashu May 13 '18 at 23:04
  • No idea, sorry :( – pomsky May 13 '18 at 23:30
6

You may use (UNITY) Tweaks to adjust font size along with other UI elements. Install it using:

sudo apt install unity-tweak-tool

The settings I'm using for scaling on a 1920x1080 monitor are 1.38 times. You would probably want 2.00 or higher:

Tweak fonts.png

The Text scaling factor scales both fonts and UI elements like title bars, menus, etc.


Here's a GIF showing changing scaling from 1.38 to 1.00 and then to 2.00:

UbuntuTweakFonts.gif

In the .gif above scaling starts at 1.38 on a 1920x1080 monitor. Then it is changed to 1 and everything gets tiny, which is normal. Then it is changed to 2 which is ideal for the visually challenged. Once again the icons have fixed pixel size and the font shrinking or expanding under the icon gives the illusion their size is changing.


There are others tweak tools that may be of interest in 18.04 LTS:

$ apt list | grep tweak
gajim-rostertweaks/bionic,bionic 1.0.0-3 all
gnome-tweak-tool/bionic,bionic 3.28.1-1 all
gnome-tweaks/bionic,bionic 3.28.1-1 all
mate-tweak/bionic,bionic 18.04.16-1 all
mousetweaks/bionic,bionic,now 3.12.0-4 amd64 [installed]
tweak/bionic 3.02-2 amd64
unity-tweak-tool/bionic,bionic,now 0.0.7ubuntu4 all [installed]
  • Getting error when trying to use this :/home/ashu# sudo unity-tweak-tool /usr/lib/python3/dist-packages/UnityTweakTool/__init__.py:40: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. from gi.repository import Gtk Error: schema com.canonical.notify-osd not installed Gtk-Message: 22:26:09.434: GtkDialog mapped without a transient parent. This is discouraged. – Ashu May 13 '18 at 3:27
  • 1
    @Ashu Gnome Toolkit (GTK) warning messages unfortunately occur all the time. Unless something is broken and doesn't work you can safely ignore them. – WinEunuuchs2Unix May 13 '18 at 3:37
  • @Ashu To avoid the messages call unity-tweak-tool from the desktop launcher or dash (Alt + F2) rather than the command line. – WinEunuuchs2Unix May 13 '18 at 13:25
  • Do we have GNome or unity by default in Ubuntu 18.04 LTS? – Ashu May 13 '18 at 14:05
  • @Ashu I think by default they are both there but I've only done 16.04 to 18.04 upgrade 4 times (on a test partition) and each time both were there. – WinEunuuchs2Unix May 13 '18 at 14:09
4

You don't need to install third-party tools if you using Unity.

Just go: Unity control center -> Displays -> Scale for menu and title bars

Now you can scale everything to a readable size: enter image description here

  • 7
    Ahem... Unity itself is a third party tool in Ubuntu 18.04 LTS (it comes with GNOME instead of Unity). – pomsky May 13 '18 at 2:02
  • @pomsky ok!?! I thought its part of the system! But your right Unity is just the default desktop enviroment! I always think defaults are not third party ....... – Stackcraft_noob May 13 '18 at 2:05
  • 9
    It's not the default desktop environment any more, Canonical ditched Unity and switched to GNOME since 17.10. – pomsky May 13 '18 at 2:07
  • @pomsky good to know! Im still on ubuntu 16 – Stackcraft_noob May 13 '18 at 2:10
  • @pomsky I think someone said on their installation Unity is the default desktop for those upgrading 16.04 LTS to18.04 LTS. (Long Term Support). The flash in the pan odd numbers (17.04, 17.10, etc) I'm not sure about. It's kind of confusing: Wayland is in, no wait Wayland is out. and more recently: Unity is out, no wait Unity is in again. Anyway I think we can look forward to two answers from now on, one for Gnome and one for Unity if OP doesn't specify a desktop. – WinEunuuchs2Unix May 13 '18 at 14:13
3

Some people suggest to just scale everything up going to Settings > Displays:

screenshot

run_scaled

As you may notice scaling up may work for decorations and almost all apps. But some apps will still look tiny. For example, MySQL Workbench have this bug since 2009.

To scale per-application windows on Xorg for HiDPIs (as Arch Wiki state) you can use run_scaled.

Install it:

sudo apt install xpra  # tool to detach/reattach running X programs
curl "https://raw.githubusercontent.com/kaueraal/run_scaled/master/run_scaled" > ~/.local/bin/
chmod +x ~/.local/bin/run_scaled

Then

run_scaled someapp

By default will scale by a factor of 2 but you can use --scale option.

2

This helped me when I upgraded from 16.04 lts to 18.04 lts:

  1. open system settings
  2. select universal access
  3. turn on large text

screenshot

  • In addition to this, you could change the scaling, System Settings->Devices->Displays and change the scaling to 200% – Bernard Wei Aug 30 '18 at 0:52
  • This fixes small font in Chrome as well. – holmberd Feb 25 at 1:07
  • The universal access changed fonts in all screens. My system was displaying fine on laptop screen, but tiny fonts on external 4k monitor. – MarkHu Apr 10 at 23:53
0

Not sure if this will help, but in XUbuntu:

  1. Lower Left corner button (where the big K is)
  2. Applications > Settings > System Settings > Font

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.