0

When I run bash ./rebuild.sh I get the following error:

vagrant@user:/var/www/html/wp-content/xdebug$ bash ./rebuild.sh
Configuring for:
PHP Api Version:         20151012
Zend Module Api No:      20151012
Zend Extension Api No:   320151012
shtool at '/var/www/html/wp-content/xdebug/build/shtool' does not exist or is not executable.
Make sure that the file exists and is executable and then rerun this script.

According to this answer I should "Remove noexec flag from /var/www/html/". When I try this, I get another error:

$ sudo mount -o remount,noexec /var/www/html/
unknown mount option `relatime'
valid options:
  rw         mount read write (default)
  ro         mount read only
  uid       =<arg> default file owner user id
  gid       =<arg> default file owner group id
  ttl       =<arg> time to live for dentry
  iocharset =<arg> i/o charset (default utf8)
  convertcp =<arg> convert share name from given charset to utf8
  dmode     =<arg> mode of all directories
  fmode     =<arg> mode of all regular files
  umask     =<arg> umask of directories and regular files
  dmask     =<arg> umask of directories
  fmask     =<arg> umask of regular files

I'm pretty stuck here as I have not found much out there on this issue. How do I 'fix' this?

UPDATE:

From the xdebug README file ./rebuild.sh : "This will run phpize, ./configure, make clean, make and make install."

When I run phpize alone I also get the same error. What is causing this?

7
  • What is rebuild.sh?
    – fkraiem
    Commented May 12, 2018 at 23:46
  • From the xdebug README file: "This will run phpize, ./configure, make clean, make and make install." When I run phpize alone I also get the same error.
    – now_world
    Commented May 12, 2018 at 23:49
  • @Hugo in the mount script?
    – now_world
    Commented May 13, 2018 at 1:37
  • @hunterint Nevermind, I was wrong
    – Baa
    Commented May 13, 2018 at 1:39
  • 1
    @Hugo see man mount, relatime is a valid option. Commented May 13, 2018 at 1:45

1 Answer 1

0

If you runnig vagrant provider virtualbox and you wnat remove relatime just put parameter norelatime like this:

mount -o remount,ttl=0,norelatime /var/www/html/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .