1

I just updated my T450s to Ubuntu 18.04 LTS and since then the connection request time is just horrible. If I make any connection to the internet, be it curl, ping or a normal website call it takes 3-5 seconds before anything happens. Only then the actuall connection is being established.

What I tried so far:

  • It is intependend of medium (WIFI/ Cable)
  • It is not the DNS as a ping to e.g. 8.8.8.8 still takes time before it starts after pressing enter
  • It is not the internet connection itself as I can download and upload with full speed and its the same issue on LAN
  • It is not a networek isuue as my dekstop computer and phone do not have this issue
  • It is not a hardware issue with the laptop as the problem does not persist with a live booted Ubuntu 18.04.

I'm pretty clueless as to what the issue is and even more so how to debug it properly. I ran strace with the ' -T ' for ping and could identify some calls that are repeatedly taking ~ one second. But I don't know enough about the internals of linux to understand that. I can post said output if neccessary.

Thanks for any help in advance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.