26

Setup

  • VirtualBox: 5.2.12 (just released)
  • Host: Windows 10 with the latest update
  • Guest: Ubuntu 18.04, 3D acceleration enabled, Gnome desktop manager
  • Video card: Nvidia GEFORCE GTX980

Behavior

Ubuntu boot, login go fine, desktop shows up, I'm able to start applications, type, move or resize windows (by grabbing the edges), etc.

However, if I maximize any window by double clicking on its title bar, or clicking on the maximize button, response to keyboard or mouse input for the entire system becomes so sluggish (20 seconds or longer response time to any key pressed in gedit for example) that Ubuntu becomes unusable and needs to be shut down (forcefully if I don't want to wait for delayed response to commands).

If I disable 3D acceleration in VirtualBox Manager, Gnome works fine, even when maximizing windows.

If I switch to Unity desktop manager, everything works fine, with or without 3D acceleration.

Since my current Ubuntu 18.04 installation is an update from an older version of Ubuntu (16.04 was the original installed version I think), I created a fresh Ubuntu 18.04 virtualbox, and the same thing happens there too, so it's likely unrelated to the updates.

Also, generally Unity seems to be faster than Gnome, even when Gnome is still responsive.

This issue started with Ubuntu 17.04 (when Gnome was made default desktop manager) and has been happening with all versions of VirtualBox versions available since then.

I would appreciate any suggestions on how to fix this.

  • 1
    Having the same problem with exact same config. VirtualBox 5.2.12, Windows 10 Host OS, Ubuntu 18.04 Guest with default display manager – mitsos1os May 15 '18 at 17:49
  • I have exactly the same issue on the same setup. – fvannee May 17 '18 at 9:21
  • 1
    I'm facing the same issue on both Windows 10 or MacOS High Sierra hosts. (Did you already post a VirtualBox bug ticket?) – kmhofmann May 21 '18 at 8:41
  • I have not posted a bug report. I'm not sure if this is an Ubuntu, VirtualBox, Windows or combination problem. Regardless, for example, there is another VB/Ubuntu issue that is fairly annoying unix.stackexchange.com/questions/52951/… that was reported in 2009 and still not resolved, so I'm not sure there is too much hope for this one either. – Ady May 23 '18 at 0:37
  • same here, Windows 10, VB 5.2 – dylanh724 Aug 30 '18 at 16:08
22

VirtualBox devs basically threw their hands up over 3D Acceleration with regards to X11 guests, as stated in this post from over 2 years ago: https://www.virtualbox.org/wiki/X11Guest3D

There are dozens of tickets created on the VirtualBox site, and all of them have gone ignored. Plenty of forum posts as well. The same reply has been given every time, the latest one I can find posted 3 weeks ago by one of the devs (michael):

I am afraid that there is currently no one on the team with enough free time to investigate this (and no sign that it will change in the foreseeable future). It should be something which interested users with skills in OpenGL programming in C should be able to track down and fix. Questions (technical ones) or patches welcome on the vbox-dev mailing list.

Going forward, the current consensus is that you have 4 options:

  1. Disable 3D Acceleration (easiest)
  2. Use any other desktop environment besides GNOME x11, such as GNOME Wayland or Unity
  3. Use any of the other virtualization products
  4. Contribute to the VirtualBox project yourself

Links: https://forums.virtualbox.org/viewtopic.php?f=3&t=84198 https://www.virtualbox.org/ticket/15417 https://www.virtualbox.org/ticket/17014 https://www.virtualbox.org/ticket/17577 https://forums.virtualbox.org/viewforum.php?f=3

  • Performance on 18.04 is pretty abysmal with 3D Acceleration disabled for me :( – jocull Jun 15 '18 at 17:57
  • Disabling 3D acceleration worked for me. It's not ideal but at least somewhat usable now. – Raul Laasner Sep 11 '18 at 17:39
4

In Virtualbox, the guest OS only sees a virtual graphics adapter provided by the virtual machine software. Installing drivers on the host won't matter and you'll probably break the installation by attempting to do so. 3D acceleration only really matters if you require it for gaming or 3d software, etc.

The 6.0 version released in December 2018 has made significant progress with the addition of a new option under the "Display" menu's "Graphics Controller" dropdown. Select VMSVGA under this option to create a virtual SVGA controller and you should be good to go.

Learn more here!

  • 1
    VMSVGA significantly improved the video issues in my VM (Surface Pro 3 Host + Windows 10, Ubuntu 18.04 Guest). Thanks!! – tresf Jan 29 at 21:26
  • Great! VMSVGA stopped the hanging on Window resize (Ubuntu 18.04 guest). Of course now there is a new problem to live with: took longer than 60 seconds to shut down guest! Guest is 4k @ 200% scale. Host Ubuntu 18.04, VirtualBox 6.06, on top spec XPS laptop but using Intel GPU with 3D on. Aside: I find Gnome is mostly stable with a low overhead to get going, but the actual usability of Gnome is really crappy. I bought VMware Workstation Pro to get around the bugs in 6.06, and it was easy to convert the Windows and Ubuntu VMs I use, but VMware had other issues to do with 4k resolution - arrggh. – robocat May 8 at 2:50
2

I had the same problem but with: Windows 7 host with NVIDIA Quadro K2100M

After reading the following article: https://www.omgubuntu.co.uk/2018/06/mesa-18-1-1-ubuntu-18-04-ppa

I decided to install it and check if 3D acceleration works. 3D is ON since then and working fine.

  • I followed these instructions, dist-upgrade shows 0 missing updates, but my OpenGL version is still 2.1: OpenGL Warning: vboxCall failed with VBox status code VERR_BUFFER_OVERFLOW OpenGL version string: 2.1 Chromium 1.9 – John Freeman Jul 28 '18 at 3:43
  • Unfortunately this solution didn't work for me :( Still laggy – 1000Gbps Aug 29 '18 at 19:11
0

I had the same issue with 3D acceleration and vbox guest additions, moving or resizing windows put the whole system very sluggish.

My problem is gone instantly after changing few settings on the virtual machine :

  • Graphics Controller : VMSVGA
  • Audio Controller : ICH AC97
  • Enable Audio Input : OFF

Hope it could help...

LL.

0

Activate the VBoxSVGA and you can still enable the 3D acceleration.

Works appropriately in my nvidia Graphics card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.