7

I updated my Ubuntu to 18.04 and now when I change the input language (either with the shortcut or by selecting the language from the top right) the scroll lock toggles, which causes my keyboard to turn on and off the blacklight every time I change the input language. I tried to replace the

XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

to

XKBOPTIONS="grp:alt_shift_toggle"

from /etc/default/keyboard but didn't work.

8

You run into this bug.

That grp_led:scroll option gets imported to dconf too. Since you already removed the option from /etc/default/keyboard, a simple way to fix it is through this command:

gsettings reset org.gnome.desktop.input-sources xkb-options
0

I had the same problem. + after opening a terminal it started to blink again.

This worked for me:

First change /etc/default/keyboard - as above:

XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

to

XKBOPTIONS="grp:alt_shift_toggle"

Than remove from .profile , .bashrc etc any calls to

setxkbmap ...

(I had setxkbmap -option 'numpad:microsoft')

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.