5

My PC freezes before the login screen (Ubuntu logo); if I select RECOVERY MODE and resume boot everything goes well. I suspect a problem with the graphics driver.

13

Finally I was able to solve the issue by uncommenting the line #WaylandEnable=false in /etc/gdm3/custom.conf

| improve this answer | |
  • 1
    This works for Ubuntu 18.10 as well. – LinuxLuigi Oct 19 '18 at 15:40
  • 1
    This was a lifesaver! Worked for me too. Thanks – Fred Jun 12 '19 at 7:22
  • This solved my problem too. Should be set as the chosen answer. But sadly these kinds of things make me still not trust Ubuntu and pushes me to back up my whole virtual machine before any update... What will happen with the next update, is it going to consider this change, is this consider by Ubuntu team as a bug ? Who knows... – jav Jun 23 '19 at 14:11
  • Works with 18.04 – MMT Jul 2 '19 at 10:24
  • Anyone knows why this works? – Nujufas Oct 4 '19 at 12:04
1

Perhaps i can supplement the answer to @Vishesh Gautam and @Marcelo4k:

In the ArchWiki page on GNOME desktop environment, it is stated that "the default display is Wayland instead of Xorg." Hence, there maybe problem if the default display server is Xorg. It is noted that Ubuntu 18.04 default display server is Xorg. This explains the issue if /etc/gdm3/custom.conf has wayland display server enabled.

@Marcelo4k has successfully troubleshoot the problem by uncommenting the line #WaylandEnable=false, so Wayland display server is disabled and Xorg will be the active display server. This is noted in Fedora documentation as the first step to disable Wayland to run Gnome on Xorg. It further recommended to add a new line under [daemon] section:

DefaultSession=gnome-xorg.desktop

The above recommendation is valid if the result of gdm3 is active (running) using systemctl status:

systemctl status gdm3 

However if gdm3 is disabled and lightdm is enabled perhaps due to upgrade from Ubuntu 16.04 to Ubuntu 18.04. Then lightdm maybe active (running) instead.

So if lightdm is inactive, do as what @Vishesh Gautam has suggested by running sudo start lightdm or running as below to start light display manager:

systemctl start lightdm

However these applies only to Gnome desktop environment. If you have other desktop environments matched with other display managers, you have to consult relevant documentations to your respective desktop environment and display managers. Again, ArchWiki provide a good introduction to Display manager and they give a relevant list on how to match which desktop environment to which display manager.

Hope this helps.

| improve this answer | |
0

This answer is applicable for lightdm.

Most probably the login display manager is not starting, try starting the Lightdm manually (if you haven't changed it, i.e Default) from TTY by the following command : sudo start lightdm

A display manager presents the user with a login screen. A session starts when a user successfully enters a valid combination of username and password.

PS : If you don't know, you can access TTY by pressing CTRL+ALT+F1/2/3/4 at the freeze point you're referring to and then login with username and password.

| improve this answer | |
  • Thanks, if freezes in "Started User Manager for UID 123" and cannot move on. – Marcelo4k May 12 '18 at 14:06
  • Exit TTY by CTRL+ALT+F7 after execution of above command, and see if it helps. – Vishesh Gautam May 12 '18 at 14:08
  • It freezes at some point of the now verbose boot. But if I go through RECOVERY MODE and resume boot I get the graphical login screen (I suppose is light dm) – Marcelo4k May 12 '18 at 14:19
  • This might help : askubuntu.com/questions/542012/… – Vishesh Gautam May 12 '18 at 14:25
  • 2
    Isn't gdm the default in Ubuntu 18.04? – Organic Marble May 12 '18 at 14:36
-1

A combination of the advice here solved the same issue for me on Ubuntu 19.10.

When the system started and hung with the mouse pointer at the bottom right of the screen, I was able to move it but there was no login window.

I pressed Ctrl+Alt+F2 to start a console session in TTY2, logged in and opened the file /etc/gdm3/custom.conf. There I uncommented the line #WaylandEnable=false (by deleting the # at the beginning of the line)

I then typed reboot and tadaaaaaa!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.