6

I am using an 18.04 installation that has been upgraded from 17.10. When it was on 17.10, I pulled the GNOME SSH/GPG agent out, in favour of using the standard, command-line SSH agent. I wrote up the steps needed to do that here.

Now, after the upgrade, I find the the keys seem to have been imported into the GNOME 3 "Passwords and Keys" app, with the problems that that entails (e.g. when keys are deleted from here, they are deleted from my ~/.ssh (!)/Keys show up with ssh-add, but aren't able to be deleted/added on the CLI). Worse still, I get a pop-up when I try to SSH into various machines for pasphrase-protected keys (though there seems to be some sort of timeout associated with this, and it seems to cache it, at least for a while).

Any ideas about how to kill the GNOME app, and go back to using the normal ssh-agent, given the thigns that I've already put in place?

  • Does seahorse works for you? – N0rbert May 12 '18 at 18:37
  • I tried a bunch of things and eventually got it working. Not exactly sure what made the difference, but in addition to following the blog post, I ran systemctl --user mask gpg-agent-ssh.socket to make sure that it wasn't hijacking the openssh agent. – David Lechner Sep 5 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.