66

In Ubuntu 17.04 there was 'Rotation' menu in Display tab. But now in new version of Ubuntu, there's still a Display tab but no more rotation menu. Now I can't turn that off again since I upgraded to 18.04 LTS.

100

The best solution I have found so far is to use the icon that is available in the top right corner of the screen, when you click on the down arrow. The icon is the one in red in the screenshot below:

screenshot with the icon

It might also look like this:

screenshot with the icon on 19.3

| improve this answer | |
  • 8
    wow.. i had no clue what it was for until my display started rotating in bed – sureshvv Aug 14 '18 at 17:21
  • 8
    What an annoying pesky little feature that I'm not sure what anyone would actually use. Can anyone enlighten me? Why would you want automatic screen orientation on a PC? – andromeda May 1 '19 at 8:28
  • 2
    I was sick of this rotation .. thanks for writing this. – Vikash May 9 '19 at 16:51
  • Unfortunately, if you're screen rotates before you sign in, it glitches out. – Amin Shah Gilani Jun 3 '19 at 22:02
  • 1
    I am using 18.04 on my PC. I don't have the icon though. Can someone explain me why? Is it maybe because my PC doesn't have rotating sensors? – Overflow Feb 11 at 11:01
34

If you want to remove this feature then fire below commands :

Try this command to stop and disable

$ sudo systemctl stop iio-sensor-proxy.service
$ sudo systemctl disable iio-sensor-proxy.service

Try this command to remove

$ sudo apt-get remove iio-sensor-proxy
| improve this answer | |
  • Do the above and use settings / displays (or gnome tweak etc) to reset the rotation manually. – Tech1337 Oct 23 '19 at 10:11
  • 1
    I am just removing those serveries. But in newer version on linux, this problem is gone. Every Linux kernel from 4.3 up to version 4.12 had a bug that made made iio-sensor-proxy fail... Visit : github.com/hadess/iio-sensor-proxy – shivang patel Oct 23 '19 at 11:35
  • I am on Pop!OS 19.10 and iio-sensor-proxy still has issues with HDAP sensors, thinking it is an orientation accelerometer. If this is the case, remove iio-sensor-proxy and install something like: hdapsd - HDAPS daemon for various laptops with motion sensors or tp-smapi-dkms - ThinkPad hardware/firmware access modules source - dkms version – Tech1337 Oct 23 '19 at 13:39
  • 1
    @Tech1337 I strongly suggest you.. Ask this same question in their forum. Btw, which kerner is currently running on 19.10 ? If this pop!OS based on ubuntu then, these issue shouldn't come... – shivang patel Oct 24 '19 at 5:35
  • 1
    I love this answer. some laptops have the sensor inside of them, not to rotate the screen but used for things like drop detection and what not. like my HP EliteBook 840. thank you for posting this, as it was the only thing that permanently fixed the issue – DPS Nov 6 '19 at 22:52
14
gsettings set org.gnome.settings-daemon.plugins.orientation active false

The above just worked for me. Seems the simplest solution

| improve this answer | |
  • It seems to me that this simply changes the default toggle state of the icon the other answers mention (default state after boot). Which is exactly what I needed! – lucidbrot Jul 19 at 12:45
13

You may use the keyboard combination Super+O to toggle the rotation lock ON/OFF as described in @Sylvain's answer.

screenshot with the icon

Note that Super is usually the key with Windows logo.

| improve this answer | |
3

What do you mean "turn off screen rotation" ? Do you mean go back to normal orientation ?

Anyway, in the new gnome-control-center of gnome 3.28, in Devices > Screen Display tab, you can click on Orientation and a menu appears to let you choose between

- Landscape
- Portrait right
- Portrait left
- Landscape (flipped)

I guess this is what you want ?

| improve this answer | |
  • This thread continues to be useful! Fixing my wife's HP-dv6 laptop's upside-down screen, I found that the Devices > Screen > Orientation option menu only appears when iio-sensor-proxy.service is stopped, disabled, and (preferably) removed per shivangpatel -- and then the spurious 'orientation' icon in the upper-right corner of the Gnome desktop screen disappears !! And the gsettings commands per vaishaldhir were also helpful to make sure those settings were correct.Thanks, all, for the information! – user31301 Mar 15 at 11:26
3

for me none of these work. As soon as I put the computer to sleep and wake it up again, it puts itself in the wrong orientation (due to the fact that the computer is sitting on a tilted support that raises it up). The only thing that I manage to do quickly is

xrandr -o normal

to fall back to normal orientation. This is painful

| improve this answer | |
  • sorry, removing iio-sensor-proxy does remove the problem of course.... But none of the proposed config fixes seem to hold after sleep/wake cycle. – Johann cohen-tanugi Jun 28 '19 at 11:17
1

use the code given below and it will work definitely

gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock true

gsettings set org.gnome.settings-daemon.plugins.orientation active false

| improve this answer | |
  • orientation-lock is the same as the <Super>+o control. – Planky Apr 5 '19 at 18:48
  • This is the most transportable answer, any other option to enable/disable affects this gnome setting. To monitor this, see the output of gsettings monitor org.gnome.settings-daemon.peripherals.touchscreen orientation-lock. – mbrownnyc Oct 14 '19 at 23:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.