4

When I switch on my laptop, it boots and goes into blinking stage. Keyboard and mouse work.

After do a force shutdown using power button and boot again, this problem is gone and it boots normally.

I did boot-repair and it didn't help me either. Or is this a common bug in 18.04

Any suggestions about installing ubuntu-desktop again as suggested here?

I did a version upgrade from Ubuntu 16.04 to 18.04. My Laptop is hp with AMD-A6 and Readon-R4 graphics.

2
  • 1
    I'm having the exact same problem. I'm not certain what it is, but I've found a good workaround. I turned off the splash screen and so far it's helped me. Here's a link that describes how to turn off your splash screen. I hope it helps! askubuntu.com/questions/248/… – Pita May 13 '18 at 16:50
  • 1
    I am also having the same problem when I boot with the default ubuntu version, however if I click on the option that allows me to choose the ubuntu version, and choose an earlier version then it runs fine. After booting with the earltier version, if I "restart" (instead of power of and then swithcing it on) and boot with default version then the problem does not occur. I did not have this problem when I initially upgraded to 18.04 but the problem started after one of the software upgrades. I have AMD (Hp laptop) with Readon-R4 graphics. – neelanshu Apr 11 '19 at 8:47
3

If you happen to have an AMD graphics card, try the solution proposed in this answer:

I solved it myself by using amdgpu.dc=0 as a boot parameter.

To do this, edit the file /etc/default/grub, for example using

sudoedit /etc/default/grub

Find the line beginning GRUB_CMDLINE_LINUX_DEFAULT and add the text amdgpu.dc=0 between the double quotes (""). Leave any other parameters as they are. For example, you may end up with a line like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.dc=0"

Save the file and exit, and then run

sudo update-grub

to write the configuration, and reboot.

1
2

While the Ubuntu screen was flickering I hit cntl-alt-del and it rebooted and when to the boot screen to select an OS. I selected Ubuntu and it booted without problems.

1

The easiest way is to:

  1. Boot your Linux in ("Recovery Mode")
  2. After going into Recovery mode, select "Update GRUB"
  3. Press ENTER on "UPDATE GRUB"
  4. Reboot

Worked for me, I had a blinking screen on my Ubuntu 18.04 with Intel graphics, but as long as you are on X drivers (by default and recommended strongly - by my opinion) you'll be fine, if not please let me know there is a way around. But, as I said, these 3-4 steps will resolve your issue with blinking splash/ boot screen when "Ubuntu is loading".

Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.