7

lsusb

Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 18a5:0246 Verbatim, Ltd 
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 0a5c:216d Broadcom Corp. 
Bus 002 Device 005: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 / TL-WN822N v2 802.11n [Atheros AR7010+AR9287]
Bus 002 Device 006: ID 0bda:a811 Realtek Semiconductor Corp. 
Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The device I'm having trouble with is 006

dkms status

8812au, 4.2.2, 4.13.0-39-generic, x86_64: installed
bcmwl, 6.30.223.271+bdcom, 4.13.0-39-generic, x86_64: installed
bcmwl, 6.30.223.271+bdcom, 4.4.0-122-generic, x86_64: installed

usb-devices

...

Bus=02 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#=  6 Spd=480 MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0bda ProdID=a811 Rev=02.00
S:  Manufacturer=Realtek 
S:  Product=802.11ac WLAN Adapter 
S:  SerialNumber=00e04c000001
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 6 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)

...

sudo lshw -class network

*-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 0c
       serial: 00:71:c2:08:aa:48
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:46 ioport:e000(size=256) memory:f7b00000-f7b00fff memory:f0a00000-f0a03fff
  *-network UNCLAIMED
       description: Network controller
       product: BCM43142 802.11b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:f7a00000-f7a07fff
  *-network
       description: Wireless interface
       physical id: 2
       bus info: usb@2:4
       logical name: wlxa0f3c11c58c4
       serial: a0:f3:c1:1c:58:c4
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=ath9k_htc driverversion=4.13.0-39-generic firmware=1.4 ip=172.20.10.5 link=yes multicast=yes wireless=IEEE 802.11

What to do to make adapter use driver?

Or have I got this completely wrong?

  • I have a txt file generated by wget -N -t 5 -T 10 github.com/UbuntuForums/wireless-info/raw/master/wireless-info && > chmod +x wireless-info && > ./wireless-info – DJJ375 May 11 '18 at 20:35
  • I would like to see what lsmod has to say – Joshua Besneatte May 11 '18 at 20:56
  • Hi, thank you for your time. lsmod has generated a lot of output - I'm not sure how to get it to you. – DJJ375 May 11 '18 at 21:06
  • put it in your question... format it as code – Joshua Besneatte May 11 '18 at 21:10
  • What is the exact response to the terminal command: sudo modprobe 8812au? Why not use the internal wireless Broadcom? – chili555 May 11 '18 at 21:12
9

I answer for future reference, having found the question myself without answer. There are a couple of problems:

  1. I had problems correctly identifying the chipset. It seems that this 0bda:a811 is the realtek chipset rtl8812au; at least for me the rtl8812au driver worked.
  2. This chipset does not work for Ubuntu 18.04-1 out-of-the-box. Even the rtl8812au-dkms driver that you can install with apt-get does not work. sudo apt-get install rtl8812au-dkms seems to install version 4.3.8 (you can check with dkms status).
  3. There is luckily a new version of the driver which does work, but you need to install it manually. See this answer. I don't fully understand if it's the driver that does not work or just some problem with the module loader.

To summarize with commands that will fix your problem:

git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git
cd rtl8812AU_8821AU_linux
sudo make -f Makefile.dkms install

After that, giving dkms status you should see a line like:

rtl8812au, 4.3.14, 4.15.0-30-generic, x86_64: installed

Reboot and it should work.

| improve this answer | |
  • Wow man! You saved me wasting more hours in looking for a correct driver to the USB Wifi Adapter I bought from Lazada! BIG thanks man! I just upvoted this! – JoenasE Sep 15 '18 at 14:30
  • I am glad the answer was helpful! – Francesco Pasa Sep 17 '18 at 7:56
  • This worked, but I had to disable secure boot so that the unsigned kernel modules can load correctly. – Étienne Feb 18 '19 at 16:09
  • Many thanks. Many thanks. – Ya. May 26 '19 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.