1

This question already has an answer here:

I upgraded to 18.04 (actually it said partial upgrade) and now have no sound, I tried to install pulseaudio as it seems to be missing but I ge the message below.

dave@Dave-PC:~$ sudo apt install pulseaudio
[sudo] password for dave: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 pulseaudio : Depends: libpulse0 (= 1:10.0-2ubuntu3.1) but 1:11.1-1ubuntu7 is to be installed
E: Unable to correct problems, you have held broken packages.
dave@Dave-PC:~$ 

How do I fix this?

marked as duplicate by Elder Geek, karel, Fabby, Eric Carvalho, N0rbert May 14 '18 at 13:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • It looks like you have some 17.10 repository in your sources.list and it's trying to install from there instead of from 18.04 for some reason. Please edit your question and include the output of sudo apt update as well. – dobey May 11 '18 at 19:53
  • I had pulse audio in 16.04 and after upgrade to 18.04 last weekend it still worked. What version did you upgrade from. I'm not sure what this partial upgrade is you did. – WinEunuuchs2Unix May 11 '18 at 19:55
  • sudo dpkg -P --force-depends libpulse0 sudo dpkg -P --force-depends libpulse-mainloop-glib0 sudo apt install libpulse0/bionic-updates sudo apt --fix-broken install sudo apt install pulseaudio – Autodidact Nov 14 '18 at 15:10
  • This is not a duplicate, please reopen this question. – Autodidact Nov 14 '18 at 15:15
-1

The error speaks itself, the missing dependency / library is libpulse which can be found in libpulse-dev package.

First purge it by (So that obsolete installation is deleted) :

sudo apt purge libpulse-dev 

And then install it :

sudo apt install libpulse-dev

And then try installing pulseaudio.

Not the answer you're looking for? Browse other questions tagged or ask your own question.