9

Neither Bluetooth connection nor USB connection is able to transfer files from Android smartphone to Ubuntu 18.04. Same devices with Ubuntu 16.04 did not show any problems. When starting Nautilus, it shows the android device, but when opening it, it stays busy and does not show any results.

Ubuntu 18.04 kernel: 4.15.0-20-generic
Android Smartphone Samsung A3, Android 7.0

kernel.log messages when connecting the phone via USB seems to be OK:

May 12 05:39:53 len kernel: [69577.277832] usb 2-1: new high-speed USB device    number 28 using xhci_hcd
May 12 05:39:53 len kernel: [69577.427116] usb 2-1: New USB device found, idVendor=04e8, idProduct=6860
May 12 05:39:53 len kernel: [69577.427122] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May 12 05:39:53 len kernel: [69577.427127] usb 2-1: Product: SAMSUNG_Android
May 12 05:39:53 len kernel: [69577.427130] usb 2-1: Manufacturer: SAMSUNG
May 12 05:39:53 len kernel: [69577.427134] usb 2-1: SerialNumber: 5203f8dd51fc142b

When starting Nautilus from shell and opening Android folder, I get the following message:

Nautilus-Share-Message: 05:41:13.818: Called "net usershare info" but it failed:  
Childprocess »net« could not be executed (No such file or directory)

My workarround at the moment: installing SSHHelper on Android and using scp to copy files via SSH.

  • do you have mtp-tools installed? phone is unlocked? – Joshua Besneatte May 11 '18 at 13:31
  • I just tested my Samsung phone on both USB and Bluetooth and both worked without issue. No additional software or configuration required. – Broadsworde May 11 '18 at 13:39
  • Not a solution, but Kubuntu 18.04 comes with kde connect that integrates android phones with desktop when connected to the same wifi. – Katu May 11 '18 at 15:55
  • installing mtp-tool does not help. On phone a popup asks for giving access, it is granted. I have added some error/warnings to the questiion above. Maybe they help to solve the problem. – Manfred Steiner May 12 '18 at 3:42
  • Same with Asus tablet on kubuntu – permeakra May 21 '18 at 6:40
3

I have the same problem with ubuntu 18.04 lts and a samsung s6 edge. When I connect the phone to my pc and open Nautilus it shows no files or folders. But I stumbled on a work around: close all instances of Nautilus, dismount the phone and turn it off without disconecting it. Then turn it on and sometimes Nautilus can see it. Hope it works for you

  • Connecting my Samsung A3 to Kubuntu 18.04 over USB was not working, also solved by connecting the phone and then restarting it while still connected. Using Dolphin rather than Nautilus since kubuntu rather than gnome, did not have to close any instances of Dolphin, just restarting the phone was enough. – B.Tanner Nov 9 '18 at 10:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.