I updated my kubuntu from 17.04 to 18.04 by updating to 17.10 and directly continuing to 18.04

After reboot Plasma didn't come up, but luckily via alt + F2 I get a bash.

I have a Dell Latitude E5450 with a Nvidia GeForce 840M, latter is a plain pain in the ass since I got this laptop. So I strongly suspect that it is the culprit this time, too.

sudo ubuntu-drivers devices

gives me

  • nvidia-390 as recommended
  • nvidia-340
  • nouveau as open source driver

I tried all of them and every time I get stuck with a black screen and a cursor, which doesn't even blink.

How can I check if the culprit is really the graphics card (again....) or something else? Which log do I have to check?

And if it is in fact the graphic card, has someone ideas how to solve this mess?

This question seems to solve the problem for Gnome, but I use kde: No GUI after Kubuntu 18.04 LTS upgrade from 17.10

sudo apt-get --reinstall install plasma-desktop

Hasn't got any effect.

  • have you tried nouveau.modeset=0 to grub when you boot? – Joshua Besneatte May 11 '18 at 13:42
  • What does it do and where exactly do I set this option? – Calamity Jane May 13 '18 at 10:19

What I finally did was a new install by shrinking my partition and install it on a new one fresh. And: Tadaaa.... I saw colours. Graphics.... and have to configure my huge load of applications again. Luckily I made a backup before.

So the upgrade performance was totally shitty, while the actual installation of the system worked. No clue why.

sudo ubuntu-drivers devices

still show the same output, but the GUI is present.

Sorry that I cannot give any more help other than: Don't upgrade, reinstall. Again upgrade it didn't work. :(


I don't think this has anything to do with your nvidia drivers. I had the exact same problem; apparently, when you run kde / plasma, you end up with nothing when running the normal upgrade procedure.

I can't find back my history, but I think I ran the following in the end:

$ sudo dpkg-reconfigure plasma-desktop
$ sudo systemctl restart display-manager.service

After that you still have to select 'plasma' as desktop before logging in! Also, then plasmashell crashed when I clicked a panel, but after ALT-F2 and typing 'plasmashell' that restarted again and then everything was ok.

Edit: added the second sudo command. I'm not 100% sure what I did, or what is needed; but if this helps someone then please add a comment ;).

  • What I did in the end was a complete reinstall. tabula rasa. Very annoying and depressing. If I had done the reinstall from the beginning I would have at least saved 2 days work, all unsaved data was gone anyway. Since it was not the first time that upgrading didn't work out I guess I will opt for the fresh install from now on. After an extensive backup of course. – Calamity Jane Aug 10 '18 at 12:04

I think it is a problem with nvidia drivers. After login to console check journalctl -xb and look on Xorg part of logs. If you have kernel 4.16 probably you should try to install v396.24 - downloadable from nvidia support site. Check what show dkms status

  • dkms status output is nvidia, 390.48 4.15.0-20-generic – Calamity Jane May 11 '18 at 13:24
  • how exactly do I call jounal -xb? I get a command "journal" not found – Calamity Jane May 11 '18 at 13:25
  • I downloaded the neweset driver from nvidia yeserday, but the installer stops with a stupid error like mentioned here: askubuntu.com/questions/798932/… – Calamity Jane May 11 '18 at 13:26
  • 1
    Sorry, my mistake. It should be journalctl -xb – mariaczi May 11 '18 at 13:27
  • journalctl -xb Gives me nvidia: loading out-of-tree module taints kernel nvidia: module license 'NVIDIA' taints kernel Disabliung lock debugging due to kernel taint .... nvidia: module verfication failed: signature and/or required key missing - tainting kernel – Calamity Jane May 11 '18 at 13:43

Try restart the plasmashell: kquitapp5 plasmashell && kstart5 plasmashell

note: I use nvidia 440 proprietary driver on KDE Neon 20.04 using 'Performance Mode' PRIME profile in nvidia-setting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.