1

I have recently fresh installed Ubuntu 18.04 after the upgrade from 17.10 failed (see this question for more about that), and now the option to use dedicated graphics card does not show up when I right-click any icon.

Setting global variable DRI_PRIME does make a command use the dedicated Radeon R5 M330, so I am sure that there are no driver related issues. However, the dedicated GPU does not show up in the Details section in System Settings; only the integrated Intel HD Graphics 520 shows up. It used to show up there as "AMD HAINAN" when using the radeon driver, and "amd radeon r5 m330" when using the amdgpu driver.

How can I make the "Use Dedicated Graphics Card" option appear in the drop-down menu when right-clicking an application icon?

EDIT: I found this line in sudo journalctl /usr/bin/gnome-shell (it is the first line in the log):

May 11 14:02:31 yassine-HP-Notebook gnome-shell[1164]: Ignoring GPU /dev/dri/card1 due to the lack of connectors
3

GNOME requires switcheroo-control in order to detect whether the system has a hybrid graphics configuration. Check this for more on that.

The fix was as easy as running one command: sudo apt install switcheroo-control, and once it was installed, everything worked as expected, so the "Use dedicated graphics card" appeared in the right-click menu, and the GPU showed up in System Settings. It did not require a reboot or restarting the session.

I still wonder why this package was not installed during the Ubuntu installation...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.