2

it's days that the fan and especially the processor of my computer are perennially 100% even if there is no real reason.

This is the situation

Can someone help me?

enter image description here

This is htop with Chrome close

enter image description here

  • @dsstorefile1 You mean using a command line as "htop" – Giovanni Giampaolo May 11 '18 at 8:49
  • @dsstorefile1 Updated the main text – Giovanni Giampaolo May 11 '18 at 8:56
  • 1
    htop hides kernel threads by default, while top doesn't. You can switch this option off in F2-settings in htop, or use top – rtaft May 11 '18 at 19:24
  • @rtaft Thanks! You Just sayed Kernel but I've not understand if it's a system problem or I Can do something for solve it – Giovanni Giampaolo May 11 '18 at 19:39
  • 1
    That time it is Chrome using up the CPU. Exit out of chrome and redo the screenshot. – rtaft May 12 '18 at 13:32
6

I see Chromium browser which is responsible for high CPU as per screenshot provided of htop command. That simply means there is something wrong with your Chromium browser. To check for problems, hit Shift+ESC to while using Chromium to bring up the Chromium task manager, and check out which sub-process is using highest CPU, it may be some extension or a Browser Tab.

Also make sure to disable "Continue running background apps when Google Chrome is closed" under Chromium Settings>Advanced. This option makes Chromium running even after all Tabs are closed which may cause high resource usage on some systems.

| improve this answer | |
  • The red bars are kernel threads, not Chrome – rtaft May 11 '18 at 19:24
  • Thanks! You Just sayed Kernel but I've not understand if it's a system problem or I Can do something for solve it – Giovanni Giampaolo May 11 '18 at 19:38
  • @rtaft Updated the main text, can u read above? – Giovanni Giampaolo May 12 '18 at 8:57
  • To clarify, this doesn't necessarily mean there is something wrong with Chromium itself, but much more likely to be an issue with a particular web page that is open, or a browser extension. – thomasrutter Jul 20 '18 at 5:37
2

I think your main issue appears to be that you are running in software rendering mode. This is utilizing your CPU instead of GPU for rendering. Go to Software & Updates on the Additional Drivers tab to make sure you are running the correct video drivers.

I also noticed in your original screenshot of htop that you were 2GB into your swap space. As you start to run out of swap space, kswapd will chew up a lot of CPU and IO. The only solutions here is to have less stuff running or to add more memory to the computer.

| improve this answer | |
1

I had the same thing and tried several things; which I'd found while debugging what the cause was:

  1. Disabled the Accelerated 2D canvas; can be found here chrome://flags/
  2. Disabled most of the GPU processes under that same page.
  3. Checked the Task Manager of chrome, which only indicated that the browser itself was taking that high CPU(i.e. 151!!)

Tried each one and restarted chrome after each, but in vain! However, Restore settings to their original defaults did work. But unfortunately, I don't know what caused the high CPU usage, but yeah that did the trick!

chrome://settings/ => Advanced Settings => Restore settings...etc

Hopefully that helps!

| improve this answer | |
0

I was facing similar problem. In my case it was because of the battery of my laptop. After I removed the faulty battery the problem was solved.

Check this link for more detail: https://askubuntu.com/a/761518/1128551

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.