Out of the box, I get gestures for scrolling and right clicking. I'm very interested in three finger gestures (like slide three fingers up to see all open windows), but it seems there is no way to get those working.

I have tried with the Extended Gestures GNOME-shell extension and touchegg, neither of which are working.

Any ideas on how to get these?


I am using XPS 15 with Ubuntu 18.04 (X.org). I have managed to get multi-gestures working for me. Kohei Yamada has developed an application called Fusuma to enable multi-touch gestures on Linux. It requires you to install Ruby on your machine if it isn't already installed.

Follow the instructions from fusuma GitHub's Readme page or you could follow these steps which worked for me:

First of all check if your current user is part of the input group. You can do that by

sudo gpasswd -a $USER input  

Then log out and log back in. Now install xdotool and libinput-tools.

sudo apt-get install libinput-tools  

sudo apt-get install xdotool  

If you haven't installed Ruby you can do that now:

sudo apt install ruby  

Now install fusuma

sudo gem install fusuma  

Deciding your gestures

This is basically creating a .yml file with the desired configuration. If you want standard gestures you can follow these instructions or feel free to tweak around to get desired gestures.

Go to your config folder in home directory.

cd ~/.config    

Now create a folder named fusuma

mkdir fusuma  
cd fusuma

In there create a file called config.yml

touch config.yml   

Now you can use your favourite text editor to enter the contents in this file.

nano config.yml   

Copy and paste the following instructions if you are using GNOME, which is the default environment in 18.04.

      command: 'xdotool key alt+Right'
      command: 'xdotool key alt+Left'
      command: 'xdotool key super'
      command: 'xdotool key super'
      command: 'xdotool key ctrl+alt+Down'
      command: 'xdotool key ctrl+alt+Up'
      command: 'xdotool key ctrl+alt+Down'
      command: 'xdotool key ctrl+alt+Up'
    command: 'xdotool key ctrl+plus'
     command: 'xdotool key ctrl+minus'

  swipe: 0.4
  pinch: 0.4

  swipe: 0.8
  pinch: 0.1

Note that the gestures that this configuration has created for you are the following:

Mult-touch Gesture | Action |
3 Fingers - Left | Go Next on Browser |
3 Fingers - Right | Go Back on Browser |
3 Fingers - Up | Show all Windows|
3 Fingers - Down | Close Exposé (Esc) |
4 Fingers - Left | Next Desktop |
4 Fingers - Right | Previous Desktop|
4 Fingers - Up | Next Desktop|
4 Fingers - Down | Previous Desktop|

After this you can run the command in terminal to test if it has installed

sudo fusuma  

nothing will happen in the terminal. Just start using your multi-touch gestures - swipe away on your touchpad.

Now all you have to do is add Fusuma and the command for it in your start-up applications.

Hope this helps.

| improve this answer | |
  • 1
    even though this works, it's not a packaged app that can be used by any user, needs minimal technical expertise. But yeah, it does work great – akxer Jun 27 '18 at 10:40
  • 1
    Works great! Thanks a lot. Note, it should be: sudo gem install fusuma – mace Sep 17 '18 at 7:44
  • 1
    Hey @RachitKinger thanks for the detailed steps, just one suggestion, after the "mkdir fusuma" step, just add the command to enter into the folder that's just been created, because people new to Linux may directly paste and run the next step "touch config.yml", which will result in the config file being generated outside of the fusuma directory. – Ghos3t Oct 12 '18 at 17:58
  • 2
    Thanks for the suggestion @Ghos3t while I have mentioned that the config file should be created inside the fusuma folder, I guess you are right that if one looks only at the code then one is likely to miss that. I have added a line to change directory now. – Rachit Kinger Oct 14 '18 at 4:38
  • 1
    @AlkisMavridis I just used the Startup Applications Tool to add the command "fusuma" without "sudo". Don't know if thats the best solution, but it works for me. – Doc Dec 21 '19 at 17:33

Ubuntu 18.04 uses Xorg as the default display server instead of Wayland. The mentioned Extended Gestures extension currently works only with Wayland.

What you need to do is choose Wayland while logging in after a restart. This link shows the same procedure but the other way around (from Wayland to Xorg).

| improve this answer | |

Working on 18.10 (XPS 9570): Simply search for "Startup application" by pressing the super key (windows key in my case) then add a new application. add the command fusuma and then reboot to test it.

| improve this answer | |

I use https://github.com/bulletmark/libinput-gestures with the following configuration:

# Browser go forward (works only for Xorg, and Xwayland clients)
gesture swipe left 3 xdotool key alt+Right

# Browser go back (works only for Xorg, and Xwayland clients)
gesture swipe right 3 xdotool key alt+Left
| improve this answer | |

I use Comfortable Swipe which perform well than fusuma as I feel. You can check the repository here. https://github.com/Hikari9/comfortable-swipe

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.