1

I have a Teclast Tbook 10 S tablet (Intel® Atom™ x5-Z8350 CPU) and I recently installed Ubuntu 18.04.

Unfortunately I cannot get the audio device working on this devices. As far as I know the drivers are prestent but the kernel can't load them.

Here is the output of dmesg | grep 8316 :

[    7.657248] bytcht_es8316 bytcht_es8316: ASoC: CODEC DAI ES8316 HiFi not registered
[    7.662138] bytcht_es8316 bytcht_es8316: snd_soc_register_card failed -517
[   11.080283] bytcht_es8316 bytcht_es8316: ASoC: CODEC DAI ES8316 HiFi not registered
[   11.084101] bytcht_es8316 bytcht_es8316: snd_soc_register_card failed -517
[  285.412516] bytcht_es8316 bytcht_es8316: ASoC: CODEC DAI ES8316 HiFi not registered
[  285.412530] bytcht_es8316 bytcht_es8316: snd_soc_register_card failed -517
[  306.902602] bytcht_es8316 bytcht_es8316: ASoC: CODEC DAI ES8316 HiFi not registered
[  306.902618] bytcht_es8316 bytcht_es8316: snd_soc_register_card failed -517
[  339.921621] bytcht_es8316 bytcht_es8316: ASoC: CODEC DAI ES8316 HiFi not registered
[  339.921641] bytcht_es8316 bytcht_es8316: snd_soc_register_card failed -517
[  340.362397] bytcht_es8316 bytcht_es8316: ASoC: CODEC DAI ES8316 HiFi not registered
[  340.362431] bytcht_es8316 bytcht_es8316: snd_soc_register_card failed -517
[  340.434842] bytcht_es8316 bytcht_es8316: ASoC: CODEC DAI ES8316 HiFi not registered
[  340.434876] bytcht_es8316 bytcht_es8316: snd_soc_register_card failed -517
[  340.646078] bytcht_es8316 bytcht_es8316: ASoC: CODEC DAI ES8316 HiFi not registered
[  340.646093] bytcht_es8316 bytcht_es8316: snd_soc_register_card failed -517

Obviously i don't get any output nor I see the device in Settings dialog (I can only see HDMI output) or executing alsamixer

Any idea on how to solve it?

Thanks

3
  • Hm...I see a related thread elsewhere about a similar problem, with links to bugzilla reports...the second one includes a kernel patch, but personally I would be wary of trying it out...
    – Hee Jin
    May 10, 2018 at 21:00
  • Did you get a sound only from headphones or from speakers too?
    – redsizzurp
    May 29, 2018 at 12:16
  • I get audio from both, but the speakers still emit sounds when i plug in the headphones
    – Nicola
    May 29, 2018 at 15:50

2 Answers 2

0

Ok I solved in this way: I recompiled the audio driver as described here (Google translate is ok to understand the steps), but before I modified the driver following this comment.

Then I used the script found in this answer in step 2 to install pulseaudio configuration for this chipset and then reboot.

At this point you should reload kernel driver whith the following code:

sudo rmmod -f snd_soc_sst_byt_cht_es8316
sudo rmmod -f snd_intel_sst_acpi
sudo rmmod -f snd_soc_es8316

sudo insmod snd-intel-sst-acpi.ko
sudo insmod snd-soc-sst-byt-cht-es8316.ko
sudo insmod snd-soc-es8316.ko
pulseaudio -k

Then I had working audio on my tablet.

0

ideapad 100s-iby linuxmint 18.04 ubuntu 18.04

i solved sound trouble(intel sst audio device)

in etc/modprobe.d create file blacklist_hdmi.conf with contents:

blacklist snd_hdmi_lpe_audio download and run this linixium sh script:

https://drive.google.com/file/d/0B99O3A0dDe67VUNMV2xfVjJKeVk/edit

in /usr/share/alsa/ucm/ create a bytcr-rt5651 folder with contents:

asound.state

bytcr-rt5651.conf

HiFi.conf

sudo alsa force-reload

rm -r ~/.pulse ~/.asound* ~/.pulse-cookie ~/.config/pulse pulseaudio -k reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .