0

I have an Elantech touchpad that is not working with Ubuntu 18.04. It doesn't recognize it at all, there's nothing about it in xinput and nothing coming up in cat /proc/bus/input/devices for example.

I've tried some of the solutions suggested for previous versions of Ubuntu, such as editing /etc/default/grub with i8042.nomux=1 and i8042.reset. The patch suggested before won't work on the current kernel as well, so I'm at a loss...anyone have any ideas?

Thanks in advance.

  • See this: askubuntu.com/questions/1033033/… – pomsky May 10 '18 at 16:54
  • Thanks, I looked in the BIOS but only stuff I found was related to low power use...tried toggling it for the touchpad but nothing changed. – Yuyuko May 10 '18 at 20:03
1

Try using these below steps:-

  1. Install the package xserver-xorg-input-libinput
  2. Uninstall xserver-xorg-input-evdev
  3. Uninstall xserver-xorg-input-synaptics
  4. Reboot and see if things work better.

got these steps from 16.04: Elantech touchpad not working on new laptop , and it worked for me

0

I had this issue and solved it by apt installing the linux-image-generic-hwe-18.04-edge and linux-image-extra-generic-hwe-18.04-edge packages. These are metapackages that contain additional drivers. This will result in installing kernel 5.0.0. It may work with kernel 4.18.0 as well, but I haven't tried that so I can't verify that. If you would rather try that, omit the "-edge" from these package names to install the version 4.18.0 packages. I was also able to get it working using some of the kernel versions on ukuu, but I wouldn't recommend doing it that way as it is unsupported and could introduce other problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.