1

I'm running Ubuntu 16.04.4 LTS.

sudo apt-get update works fine, but when I run sudo apt-get upgrade I get these errors: (NOTE: I have already changed the download server from source.list to archive.ubuntu.com instead of pt.archive.ubuntu.com)

/etc/apt# sudo apt-get upgrade --fix-missing
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libdrm2 linux-generic linux-headers-generic linux-image-generic
The following packages will be upgraded:
  apache2 apache2-bin apache2-data apache2-utils apport cloud-guest-utils distro-info-data gcc-5-base grub-common grub-legacy-ec2 grub-pc grub-pc-bin grub2-common hdparm ifupdown libicu55
  libpam-modules libpam-modules-bin libpam-runtime libpam0g libpci3 libperl5.22 libplymouth4 libpython3.5 libpython3.5-minimal libpython3.5-stdlib libseccomp2 libssl1.0.0 libstdc++6 linux-base
  lshw lxcfs lxd lxd-client mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server mysql-server-5.7 mysql-server-core-5.7 open-vm-tools openssl patch pciutils perl perl-base
  perl-modules-5.22 plymouth plymouth-theme-ubuntu-text python-apt-common python3-apport python3-apt python3-distupgrade python3-problem-report python3.5 python3.5-minimal snap-confine snapd
  sosreport ubuntu-core-launcher ubuntu-release-upgrader-core wget xdg-user-dirs
63 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 15.7 MB/67.5 MB of archives.
After this operation, 3,140 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Err:1 http/security.ubuntu.com/ubuntu xenial-security/main amd64 libpython3.5 amd64 3.5.2-2ubuntu0~16.04.4
  403  Forbidden [IP: 91.189.88.149 80]
Ign:2 http/security.ubuntu.com/ubuntu xenial-security/main amd64 python3.5 amd64 3.5.2-2ubuntu0~16.04.4
Ign:3 http//security.ubuntu.com/ubuntu xenial-security/main amd64 libpython3.5-stdlib amd64 3.5.2-2ubuntu0~16.04.4
Err:1 http//security.ubuntu.com/ubuntu xenial-security/main amd64 libpython3.5 amd64 3.5.2-2ubuntu0~16.04.4
  403  Forbidden [IP: 91.189.88.149 80]

......................

update-initramfs: Generating /boot/initrd.img-4.4.0-62-generic
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
E: Failed to fetch http//security.ubuntu.com/ubuntu/pool/main/p/python3.5/libpython3.5_3.5.2-2ubuntu0~16.04.4_amd64.deb  403  Forbidden [IP: 91.189.88.149 80]

E: Failed to fetch http//security.ubuntu.com/ubuntu/pool/main/p/python3.5/python3.5_3.5.2-2ubuntu0~16.04.4_amd64.deb  403  Forbidden [IP: 91.189.88.149 80]

E: Failed to fetch http//security.ubuntu.com/ubuntu/pool/main/p/python3.5/libpython3.5-stdlib_3.5.2-2ubuntu0~16.04.4_amd64.deb  403  Forbidden [IP: 91.189.88.149 80]

E: Failed to fetch http//security.ubuntu.com/ubuntu/pool/main/p/python3.5/python3.5-minimal_3.5.2-2ubuntu0~16.04.4_amd64.deb  403  Forbidden [IP: 91.189.88.149 80]

Thanks! R.L.

1

Try seeing if your file is corrupted in your local apt repository. Reset it using

sudo rm -fr /var/lib/apt/lists/*
  • No, it didn't worked!!! The problem stays the same!!! – R.L. May 10 '18 at 16:21
  • Sometimes the packages are held back because they require the installation of new packages and sudo apt-get upgrade does not install new packages. To install the required new packages you can run Code: sudo apt-get dist-upgrade To note this only updates the current release and does not upgrade that to another, newer, release (like upgrading from 14.04 to 16.04, it will not do that) Basically apt-get upgrade only updates packages that exist on the system. But will never install new packages. apt-get dist-upgrade will install new packages if the updates require them. – Rokko May 11 '18 at 17:35
  • I've done that but... problem remains... Error 403 forbidden!!! What else can I try? – R.L. May 14 '18 at 13:16
  • See if this article might help: tecmint.com/upgrade-ubuntu-16-04-to-16-10 – Rokko May 14 '18 at 17:50
  • Just summarizing the guide. sudo apt update sudo apt dist-upgrade sudo apt-get install update-manager-core sudo nano /etc/upgrade-manager/release-upgrades prompt=normal sudo do-release-upgrade Should do it for you. – Rokko May 14 '18 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.