3

when running unity-control-center i get:

/usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37: undefined symbol: wl_proxy_marshal_constructor_versioned
Failed to load module: /usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libinfo.so

and when running gnome-control-center I get:

gnome-control-center: symbol lookup error: /usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37: undefined symbol: wl_proxy_marshal_constructor_versioned

and when I start it through the UI I simply get a popup that says something like "system error, would you like to report?"

I have no idea when this started happening since I haven't used the control center in a while. and any fix I've tried has been fruitless but I've only tried reinstalling.

any help is welcome!

here is the output from "apt-cache policy libwebkit2gtk-4.0-37" (translated from swedish to english since my system is in swedish, sorry)

libwebkit2gtk-4.0-37:
      Installed:    2.20.2-0ubuntu0.16.04.1
      Candidate:    2.20.2-0ubuntu0.16.04.1
      Version table:
      *** 2.20.2-0ubuntu0.16.04.1 500
          500 http://se.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
          500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
          100 /var/lib/dpkg/status
      2.10.9-1ubuntu1 500
          500 http://se.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
N: Ignoring file ”00trustcdrom.backup.20171209” in the directory”/etc/apt/apt.conf.d/” because it has an invalid file extension
N: Ignoring file ”00aptitude.backup.20171209” in the directory ”/etc/apt/apt.conf.d/” because it has an invalid file extension
N: Ignoring file ”01autoremove-kernels.backup.20171209” in the directory ”/etc/apt/apt.conf.d/” because it has an invalid file extension

and here is the output for "sudo apt-get update" (also translated)

Good:1 http://se.archive.ubuntu.com/ubuntu xenial InRelease
Read:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]                       
Good:3 http://ppa.launchpad.net/bit-team/stable/ubuntu xenial InRelease                                    
Good:4 http://se.archive.ubuntu.com/ubuntu xenial-updates InRelease                                        
Good:5 http://se.archive.ubuntu.com/ubuntu xenial-backports InRelease               
Good:6 http://download.mono-project.com/repo/debian wheezy InRelease                                         
Read:7 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [67,5 kB]
Read:8 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [72,6 kB]
Read:9 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [107 kB]
Read:10 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [142 kB]
Read:11 https://download.01.org/gfx/ubuntu/16.04/main xenial InRelease [3 651 B]
Ign:11 https://download.01.org/gfx/ubuntu/16.04/main xenial InRelease
downloaded 499 kB in 1s (464 kB/s)
reading packet lists… done
N: Ignoring file ”00trustcdrom.backup.20171209” in the directory”/etc/apt/apt.conf.d/” because it has an invalid file extension
N: Ignoring file ”00aptitude.backup.20171209” in the directory ”/etc/apt/apt.conf.d/” because it has an invalid file extension
N: Ignoring file ”01autoremove-kernels.backup.20171209” in the directory ”/etc/apt/apt.conf.d/” because it has an invalid file extension
W: GPG-Error: https://download.01.org/gfx/ubuntu/16.04/main xenial InRelease: 
The following signatures couldn't be verified because the public key isn't available: NO_PUBKEY 56A3DEF863961D39
W: The repository 'https://download.01.org/gfx/ubuntu/16.04/main xenial InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
  • Have you installed from some PPA that pulls in a different version of webkit perhaps? – dobey May 10 '18 at 14:34
  • I'm not sure what that is or how I would know if that was the case. I'm not a very experienced linux user. I'm willing to provide stuff that I've done that could have resulted in this error but I have no idea of what would be relevant. – Karl Blixt May 10 '18 at 15:25
  • When I try and update ubuntu with sudo "apt-get dist-upgrade" I get an error that says that some datafiles for some of the packages failed to download. but that is for flashplugin-installer... so idk. – Karl Blixt May 10 '18 at 15:26
  • When you run sudo apt-get update are any of the URLs for a domain other than archive.ubuntu.com or archive.canonical.com? – dobey May 10 '18 at 16:30
  • Also please edit your question and include the output of apt-cache policy libwebkit2gtk-4.0-37. – dobey May 10 '18 at 16:32
2

I solved the issue by restoring from backup the file

/usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37

that was mentioned in the error message. The file that broke unity-control-center were a link to a file called

libwebkit2gtk-4.0.so.37.28.2 

while my old file and now working, is a link to the file

libwebkit2gtk-4.0.so.37.14.10

booth files exists and the link wasn't broken. It was just the wrong version of the file that was needed. what the file does, I have no idea but this is were this nightmare, hopefully, ends.

  • 1
    I have a similar problem (with different packages, though: libgtk-3.so.0 and libgiomm-2.4.so.1). How do you see the links from libwebkit2gtk-4.0.so.37 to libwebkit2gtk-4.0.so.37.28.2 or libwebkit2gtk-4.0.so.37.14.10? – Helen Craigman Jul 25 '18 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.