0

I have plugged my arduino over the usb port and is recognized in /dev/ttyACM0 port according to my dmesg:

[ 3269.509330] cdc_acm 1-6:1.0: ttyACM0: USB ACM device
[ 3312.346228] usb 1-6: USB disconnect, device number 6
[ 3329.402161] usb 1-6: new full-speed USB device number 7 using xhci_hcd
[ 3329.532105] usb 1-6: New USB device found, idVendor=2341, idProduct=0001
[ 3329.532114] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[ 3329.532120] usb 1-6: Product: Arduino Uno
[ 3329.532126] usb 1-6: Manufacturer: Arduino (www.arduino.cc)
[ 3329.532131] usb 1-6: SerialNumber: 6493234363835111B171
[ 3329.532394] usb 1-6: ep 0x82 - rounding interval to 1024 microframes, ep desc says 2040 microframes
[ 3329.533486] cdc_acm 1-6:1.0: ttyACM0: USB ACM device

But id I perform an ls -l /dev/ttyACM0 is is shown in group tty instead of group dialout:

$ ls -l /dev/ttyACM0
crw--w---- 1 root tty 166, 0 Μάι  10 16:06 /dev/ttyACM0

As a result:

  1. I get the following error when I try to open the serial console in Arduino IDE:

    Error opening serial port '/dev/ttyACM0'. Try consulting the documentation at http://playground.arduino.cc/Linux/All#Permission

  2. The screen /dev/ttyACM0 command shows nothing.

Do you know how I will fix that or make when arduino is plugged in to set it into a different port as group dialout eg. /dev/arduino0?

Ps My user is in group dialout as groups command shows:

pcmagas adm tty uucp dialout cdrom sudo dip plugdev lpadmin sambashare docker lxd wireshark
0

Sometimes if you have put a service to allocate the port is is impossible to send or send data to the arduino. In order to do that disable any service that allocate the required USB port with the following command set:

sudo systemctl stop serial-getty@ttyACM0
sudo systemctl disable serial-getty@ttyACM0

Usually the common suspect is the service serial-getty in case you play with other boards (such as raspberry pi).

Further answers can be found over: http://forum.arduino.cc/index.php?topic=546660.msg3726479#new

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.