31

After upgrade from Ubuntu 17.10 to 18.04 the bootprocess takes 30s longer than before.

it stops for 30 seconds at the step

Begin: Running /scripts/local-premount

Then it continues.

At first it continued one step further to

scanning for btrfs file systems

so I uninstalled btrfs support, but that didn't help with the problem.

I see no notice of that step neither in dmesg nor in var/log/boot.log

How can I debug this problem? Can I enable additional logging?

54

Try the following:

  • open /etc/initramfs-tools/conf.d/resume
  • replace RESUME=UUID=xxx with RESUME=none
  • issue sudo update-initramfs -u
  • reboot your system

The file should contain the UUID of your swap partition, you can check this with sudo blkid | grep swap.

I found the following bug on launchpad which is supposed to be Lubuntu specific but the commands above also resolved the same issue on my Xubuntu installation.

See comments #27 and #28.

This file seems to be related to hibernate/suspend, I can confirm suspend still works on my system after the changes.

  • 3
    thanks, that worked! I also posted your solution here: unix.stackexchange.com/a/443272/20661 – rubo77 May 16 '18 at 21:39
  • I removed my swap parition manually before upgrading, but I guess it was still remembered somewhere as the RESUME field was set to the old UUID. Setting it to none shaved at least 30s from my bootup time! Top! – Michel Jun 9 '18 at 10:03
  • For me the issue was that I didn't have a swap partition at all (no idea how that happened). I fixed my problem by creating a swap partition and adding it to the file as described in this answer. – tjespe Nov 26 '18 at 15:45
  • I'm not sure what do you mean with "The file should contain the UUID...". I have two TYPE="swap" UUID, the real (/dev/sda6) and the mapped (/dev/mapper/cryptswap1). Maybe this happen if you don't have swap partition OR its encrypted. Anyway, I left the =none and everything works fine now. – Pablo A Dec 24 '18 at 3:36
  • add: in Ubuntu 18.10 /etc/initramfs-tools/conf.d/resume not exists, so I created it and RESUME=none did it for me. – NoAngel Dec 27 '18 at 6:13
1

I had the same problem with all the install of Ubuntu.

I'm using LVM with swap on a LV.

On a desktop /etc/initramfs-tools/conf.d/resume is referring to an UUID which avoid the possibility to hibernate.

On a Server /etc/initramfs-tools/conf.d/resume does not exists after install and introduce delay at boot and/or lvmetad error.

sudo su -c 'echo RESUME=/dev/mapper/the_swap_LV_name > /etc/initramfs-tools/conf.d/resume' 
sudo update-initramfs -u

https://launchpad.net/bugs/1768230

No more delay at boot or lvmetad error.

Kind Regards

Not the answer you're looking for? Browse other questions tagged or ask your own question.