32

I have upgraded to ubuntu 18.04 LTS the display brightness controls are not working. It appears that the brightness is in its lowest level and I am not able to change display brightness at all. It was working on 16.04 LTS. My laptop uses Intel Graphics card.

I have tried to solve that by creating the file /usr/share/X11/xorg.conf.d/20-intel.conf with the following content. It worked the first time, but after one reboot it remains back to the previous problem.

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

What can I do?

5
  • Does the Screen Brightness slider in Settings > Power show at all, or is it greyed out? May 10, 2018 at 4:14
  • The screen brightness slider in Settings->Power does not work, the screen brightness does not change. May 10, 2018 at 12:52
  • Ok, I solved the problem by installing xbacklight and adding it to startup applications. May 10, 2018 at 14:28
  • I rebooted the computer again and the problem came back. May 10, 2018 at 18:11
  • Lenovo Z570. Intel Graphics i915. If you have two folders acpi_video0 and intel_backlight under /sys/class/backlight/ then you need to remove acpi_video0 by adding acpi_backlight=none parameter to /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT. Do not forget to run sudo update-grub and reboot
    – x4444
    Apr 23, 2020 at 3:40

9 Answers 9

41

I also had this problem, but on different distributions the solution was different.

Solution provided by Anas Elazhar worked well until I switched to Xubuntu:

Open the file /etc/default/grub using gedit or any other text editor. Find below line.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"  

Change above line to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

If it doesn't work for you either try to change acpi_backlight value to video:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=video"

Also create the file /usr/share/X11/xorg.conf.d/80-backlight.conf but content is slightly different from the file that you created:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"     "sna"
    Option      "Backlight"       "acpi_video0"
    BusID       "PCI:0:2:0"
EndSection

If combination acpi_backlight=video with this file doesn't work change acpi_backlight back to vendor.

And do not forget to run sudo update-grub command in terminal every time you change /etc/default/grub!

8
  • 1
    adding of ` acpi_backlight=vendor` was enough (+restart). Ubuntu 18.04. Samsung R510
    – it3xl
    Apr 13, 2019 at 21:08
  • 2
    XUbuntu 18.04 on Lenovo Thinkpad T480s: acpi_backlight=video and file 80-backlight.conf did the trick.
    – kiltek
    Jul 6, 2019 at 18:52
  • 3
    No Joy with this answer SADLY Thanks anyway Nov 12, 2019 at 22:20
  • XUbuntu 18.04 on Lenovo Thinkpad T420: acpi_backlight=video worked. Mar 1, 2020 at 5:55
  • I am using Ubuntu 20.04 on HP Laptop. I was getting Unknown Display in display manager because of which I was not able to add secondary monitor or adjust screen brightness. After a lot of searching I landed on this answer and it worked perfectly. acpi_backlight=vendor + sudo update-grub + restart did the trick. Thank you !
    – Harshil
    Aug 1, 2020 at 11:25
9

Open the file /etc/default/grub using gedit or any other text editor. Find below line.

  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"  

Change above line to

  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

This would ensure to load device specific drivers before default drivers in Linux.

Save the file and close text editor.

Open terminal and run below command to update grub.

  sudo update-grub

Reboot.

After reboot, try adjusting brightness using Laptop dedicated control keys. Good Luck.

5
  • 4
    I did that, but it does not work in my laptop. May 18, 2018 at 12:29
  • Try ducky's answer May 23, 2018 at 13:53
  • This answer successsfully made my laptop react to screen brightness keys... but it now has only one possible setting of brightness. (Haven't tried ducky's answer yet)
    – lucidbrot
    May 9, 2020 at 10:22
  • Setting acpi_backlight=video instead (and running sudo update-grub && reboot ) instead of vendor worked for me
    – lucidbrot
    May 9, 2020 at 10:28
  • Not working for ubuntu 21.04 on Samsung Galaxy book pro
    – Rowing0914
    Jan 3 at 12:11
3

Installing Brightness Controller helped me in fixing up the issue

 sudo add-apt-repository ppa:apandada1/brightness-controller
 sudo apt update
 sudo apt install brightness-controller

You can access the Brightness Controller after download by searching for it.

4
  • Just added an unworkable small brightness controller window ... Useless for my rig sadly Nov 12, 2019 at 22:39
  • It fails on line three because of some unsatisfiable dependency: sni-qt. Nov 15, 2019 at 9:41
  • Now it's been fixed Jan 16, 2020 at 19:37
  • Not working for ubuntu 21.04 on Samsung Galaxy book pro
    – Rowing0914
    Jan 3 at 12:11
1

Based on my current Ubuntu 18.04 installation (from today), I can adjust brightness at the login screen with the function keys (out of the box!). However, I am using i3 with Gnome, and after login, I am no more shown brightness controls in Gnome control centre.

Above answers didn't unfortunately work for me: Instead, using Ducky's xorg script together with Grub option made my i3 + Gnome session having undesired display behaviour and getting slower.

Anyway, at least for the case you go for a non-Gnome session (e.g. i3), I can point you to https://github.com/szekelyszilv/ybacklight which (given you have meson and ninja installed) can be built by:

  • downloading, unpacking and changing into ybacklight main directory
  • mkdir build; meson build; cd build; ninja install

or, (without those tools and if you don't want to install it in the system), by:

  • cd src; gcc ybacklight.c -o ybacklight; cp ybacklight to-your-pref-dir

and then be attached to function keys via WMs config. E.g. in i3wm, I added:

bindsym XF86MonBrightnessUp exec ybacklight -inc 10 
bindsym XF86MonBrightnessDown exec ybacklight -dec 10 

to my .config/i3/config.

Furthermore, setting brightness requires root privileges, e.g., achievable with "sudo ybacklight ..." as well as an entry to /etc/sudoers: see How can I add a new user as sudoer using the command line?

2
  • 1
    You can also just build it with cd src; gcc ybacklight.c -o ybacklight. To set the brightness, it needs root privileges, so I used sudo (and added an appropriate entry to /etc/sudoers).
    – Mark
    May 30, 2018 at 1:04
  • Thx, absolutely right. Far better than my solution with chmod.
    – Mario
    May 30, 2018 at 7:45
1

I've recently updated to 18.04 and I have found that changing GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub to the following

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=video"

and adding,

Option         "RegistryDwords" "EnableBrightnessControl=1"

to /etc/X11/xorg.conf under

Section "Device"

fixed the control and brightness keys issues running Nvidia 390 driver.

4
  • 1
    GuyFork's answer WILL brick your GTK. DO NOT USE HIS INSTRUCTIONS.
    – mortal
    Jun 27, 2018 at 23:11
  • 1
    @tak I really don't see how this could affect your hardware. If you are sure, please post an answer explaining exactly what you did and what happened.
    – terdon
    Jun 28, 2018 at 8:46
  • @tak maybe this will not work for everyone just like a lot of other post/instructions from various groups did not work for me. if it doesn't work for you, you can always purge remove nvidia* and try another way as i have done many times with many laptops and various releases.
    – GuyFork
    Jul 13, 2018 at 18:37
  • 1
    It also broke my system. It was not loading until I remove /etc/X11/xorg.conf file in recovery mode. Do not recommend to use it. Jan 22, 2019 at 13:37
0

I started the nvidia X server settings and in the x server display configuration changed the selection to X Screen0 and it worked.

The brightness control works now. Also before doing that I've changed the grub to acpibacklight=video0.

1
  • Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Aug 24, 2018 at 8:44
0

On Ubuntu 18.04 (with xfce desktop) my brightness problem finally solved.

I opened 'Onboard Settings' under the 'Settings' menu. If your desktop doesn't have one, you can download it from Software Center.

On the 'Onboard Preferences' window, click the Layout menu, then choose the 'Full Keyboard' (Desktop keyboard with edit and function keys). Click here to view the Onboard Settings window

0

I managed to get Brightness control working with nvidia drivers on Debian 10.

Here is my hardware : - ThinkPad P51 - Nvidia Quadro M2200 GPU + Intel GPU

Here is how I did :

  • Go to Bios and configure display to Discrete graphics (only Nvidia GPU will be used)

  • Remove Nouveau driver if it is setup

    Add nouveau blacklist to /etc/modprobe.d/nvidia-installer-disable-nouveau.conf

    blacklist nouveau options nouveau modeset=0

    then run

    update-initramfs -u

    then reboot

  • Download and install latest Nvidia driver from Nvidia website (https://www.nvidia.com/Download/index.aspx?lang=en) Mine was version 430.50

    Open a tty console without any X Server launched (Ctrl+Alt+F3 at login page)

    Install linux headers if you don't have ( apt-get install linux-headers-`uname -r` )

    Install driver as root ./NVIDIA-Linux-x86_64-430.50.run (erase libs if requested)

That's it everyting working perfectly finally !!

0

After creating the file /usr/share/X11/xorg.conf.d/80-backlight.conf and rebooting, I experienced blank screen and I couldn't do anything about it. I have a dual boot machine, so I solved my problem by booting into windows, downloading software to access Linux files and then I deleted the /usr/share/X11/xorg.conf.d/80-backlight.conf that was causing the problem.

The way I solved my problem:

  1. sudo nano /etc/default/grub
  2. search and change this line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="
  3. sudo update-grub
  4. Reboot
1
  • After a few days, I faced a problem with my functions keys that turn on and off my led keyboard and also the display mode utility. So I removed the splash acpi_osi= from grub file and after the reboot, I was able to control my lost function keys. Though I lost the screen brightness control and because I didn't want to lose more time in searching I just installed the brightness controller as described by @SivagamiNambi above. Dec 22, 2020 at 12:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.